Light oj 1043(数学)

 

 

See the picture below.

 

 

You are given ABAC and BCDE is parallel to BC. You are also given the area ratio between ADE and BDEC. You have to find the value of AD.

Input

Input starts with an integer T (≤ 25), denoting the number of test cases.

Each case begins with four real numbers denoting AB, AC, BC and the ratio of ADE and BDEC (ADE / BDEC). You can safely assume that the given triangle is a valid triangle with positive area.

Output

For each case of input you have to print the case number and AD. Errors less than 10-6 will be ignored.

Sample Input

4

100 100 100 2

10 12 14 1

7 8 9 10

8.134 9.098 7.123 5.10

Sample Output

Case 1: 81.6496580

Case 2: 7.07106781

Case 3: 6.6742381247

Case 4: 7.437454786

 

 

题意:已知AB, AC, BC, ADE与DEBC面积比值,求AD.

分析:ADE与ABC面积之比等于AD与AB之比

 

 

 

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
#include<math.h>
using namespace std;
typedef long long LL;
#define maxn  55000
#define INF 1e+7

int main()
{
    int T, t=1;
    double ab, ac, bc, r,ad;

    scanf("%d", &T);

    while(T --)
    {
        scanf("%lf %lf %lf %lf", &ab, &ac, &bc, &r);

         r = r /(r+1);
         r = sqrt(r);
         ad = ab * r;
        printf("Case %d: ",t++);
        printf("%.10f\n",ad);

    }
    return 0;
}
View Code

 

 

 

 

 

转载于:https://www.cnblogs.com/daydayupacm/p/5755542.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值