ACM1000(移动桌子)

问题描述:

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 


The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
Output
The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input
  3
  4
  10  20 30 40 50 60 70 80
  2
  1 3 2 200
  3
  10 100 20 80 30 50
Sample Output
  10
  20
  30
 题意:
公司有400个房间,单号对双号对门,中间有一条走廊,
现在要搬东西,给出要搬的次数,还有每次搬动的房间号,
每次搬动需要10分钟,搬动过程中的那段走廊不能被使用,
求最大搬动时长。
测试数据:输入
     1
     4
     10 20 35 15 16 10
输出:  
     30

问题分析,四百个房间,令1-2,3-4.....399-400每一对相对房间定为一段走廊,共计200段,移动桌子的使用的时间,只需要计算用的最多的走廊段,然后*10即可
代码:

#include <iostream>
using namespace std;

int main()
{
  int i,j,k;//k用于交换,若开头房间号大于结尾房间号
  int s,e;//房间开始和结束

  int t,num;
  cin >> t;
  while(t--)
  {
    int corr[200] = {0};//定义走廊段
    cin >> num;
    for(i = 0;i < num;i++)
    {
      cin >> s >> e;
      if(s > e)
      {
        k = s;
        s = e;
        e = k;
      }
      for(j = (s-1)/2;j <=(e-1)/2;j++)//j<=(e-1)/2不要忘了是<=,因为(e-1)/2也是使用的走廊段
        corr[j]++;          //将移动桌子需要的走廊段自增,计算该段走廊使用的次数
    }

  //找出使用最多的走廊段,输出使用时间
    int maxt = 0;
    for(i = 0;i < 200;i++)
      if(corr[i] > maxt)
      {
        maxt = corr[i];
      }
    cout << maxt*10 << endl;
  }
  return 0;
}

 

 

转载于:https://www.cnblogs.com/2016zhanggang/p/5318865.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值