每周一题2_杭电ACM_Moving Tables

7 篇文章 0 订阅

Moving Tables

题目来源:杭电ACM 1.3.1

原题描述

Problem Description
·
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
在这里插入图片描述
The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
在这里插入图片描述
For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
·
Input
·
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
·
Output
·
The output should contain the minimum time in minutes to complete the moving, one per line.
·
Sample Input
·
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
·
Sample Output
·
10
20
30

大致意思就是:

有一条走廊,两边各有两百个总共四百个房间(有编号的),任务是在这些房间之间移动桌子。

当一张桌子从房间 s 移动到房间 t,那它们之间的走廊部分就被征用了,这部分的房间就不可以移动桌子,其他部分的房间可以移动桌子。

移动一张桌子需要十分钟,求最短的移动桌子所花的时间。

测试代码

/*
作者:童话
环境:Win 10 & Visual Studio 2019
时间:2021-3-26
*/
#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>

int main(void)
{
	int T;			//	测试样例
	int N;			//	桌子数目
	int s, t;		//	房间号码
	
	(void)scanf("%d", &T);
	
	while (T--)		//	T个测试样例的循环 
	{
	
		int max = 0;
		int mark[201] = { 0 };	//走廊的标记数组
		
		(void)scanf("%d", &N);
		
		while (N--)	//	N个桌子的循环 
		{
			(void)scanf("%d %d", &s, &t);
			
			if (t < s)	//	保证 s<t
			{
				int temp = t;
				t = s;
				s = temp;
			}
			//对半折,因为房间是相对排布的,相当于是走廊的部分
			s = (s + 1) / 2;
			t = (t + 1) / 2;
			//被占用的走廊部分+1表示被用了 1 次
			for (int i = s; i <= t; i++)
			{
				mark[i]++;
			}	
		}
		//找出走廊标记的最大值
		for (int i = 1; i < 201; i++)
		{
			if (mark[i] > max)
			{
				max = mark[i];
			}
		}
		//输出结果(最大值的10倍)
		printf("%d\n", max * 10);
	}
	return 0;
}

小结一下

由房间号码得出走廊号码 --> 初始化走廊数组为0 -->

被占用的走廊部分数组+1 --> 房间输入完之后,求出数组的最大值 -->

输出最大值的10倍即可。

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

童话与云

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值