ZOJ - 3780-Paint the Grid Again-(拓扑排序)

Description

Leo has a grid with N × N cells. He wants to paint each cell with a specific color (either black or white).

Leo has a magical brush which can paint any row with black color, or any column with white color. Each time he uses the brush, the previous color of cells will be covered by the new color. Since the magic of the brush is limited, each row and each column can only be painted at most once. The cells were painted in some other color (neither black nor white) initially.

Please write a program to find out the way to paint the grid.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 500). Then N lines follow. Each line contains a string with N characters. Each character is either 'X' (black) or 'O' (white) indicates the color of the cells should be painted to, after Leo finished his painting.

Output

For each test case, output "No solution" if it is impossible to find a way to paint the grid.

Otherwise, output the solution with minimum number of painting operations. Each operation is either "R#" (paint in a row) or "C#" (paint in a column), "#" is the index (1-based) of the row/column. Use exactly one space to separate each operation.

Among all possible solutions, you should choose the lexicographically smallest one. A solution X is lexicographically smaller than Y if there exists an integer k, the first k - 1 operations of X and Y are the same. The k-th operation of X is smaller than the k-th in Y. The operation in a column is always smaller than the operation in a row. If two operations have the same type, the one with smaller index of row/column is the lexicographically smaller one.

Sample Input

2
2
XX
OX
2
XO
OX

Sample Output

R2 C1 R1
No solution
 
 
 
 
 
 
  
 
 
 
 
 
 
分析:
一开始就想到了用图论来解决
我首先想到了如何建图:
由于每个点最多会被涂两次(R一次,C一次)。
由于R和C涂的颜色是不一样的,我们可以根据这个点的目标颜色判断出对这个点的这两次操作的先后顺序。
由此可以按先后顺序建一条边。
我们的目的就是求出一条路径满足所有这些条件(即拓扑排序)
最后题目要求字典序最小的方案,由于列变换字符'C'的字典序比行变换'R'的字典序小,因此把列号设为1~n,行号设为n+1~2n,而且要求变换的行列坐标也要最小,因此用最小堆的优先队列来代替普通队列进行拓扑排序,
另外注意一点,起点(第一个入度为0的点)是不用涂的。因为起点在后面涂的时候一定会被覆盖
比如单一个点'X',拓扑序为第1列->第1行,但是显然刷第1列这个操作是多余的。
代码:
#include<bits/stdc++.h>
using namespace std;
const int MAXN=1030;
struct edge
{
    int e;
    int nxt;
    edge():nxt(0){};
    edge(int e2,int nxt2):e(e2),nxt(nxt2){};
}e[MAXN*MAXN];
int head[MAXN];
int tot;
int deg[MAXN];
    int n;
void add(int b,int ee)
{
    e[tot]=edge(ee,head[b]);
    head[b]=tot++;
}
std::vector<int> res;
int non[MAXN];
bool topo()
{
    priority_queue<int,vector<int>,greater<int> > q;
    for(int i=1;i<=2*n;i++){ //!注意是2*n
        if(deg[i]==0){
            q.push(i);
            //res.push_back(i);
            //cout<<"push "<<i<<endl;
            non[i]=1;
        }
    }
    int t;
    int now;
    while(!q.empty()){
        t=q.top();
        q.pop();
        res.push_back(t);
        for(int i=head[t];i!=0;i=e[i].nxt){
            now=e[i].e;
            deg[now]--;
            if(!deg[now]){
                q.push(now);
            }
        }
    }
    //cout<<"size "<<res.size()<<endl;
    return res.size()==n*2;//!注意是2*n
}
void init(){
    memset(head,0,sizeof(head));
    memset(deg,0,sizeof(deg));
    tot=1;
    res.clear();
    memset(non,0,sizeof(non));
}
int main()
{
    //freopen("data.in","r",stdin);
    int t;
    scanf("%d",&t);
    char ch;
    while(t--){
        init();
        scanf("%d",&n);
        getchar();
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                ch=getchar();
                if(ch=='X'){
                    add(j,i+n);deg[i+n]++;
                }
                else{
                    add(i+n,j);deg[j]++;
                }
            }
            getchar();
        }
        if(!topo()){
            printf("No solution\n");
        }
        else{
            int now=0;
            int len=res.size();
            for(int i=0;i<len;i++){
                now=res[i];
                if(non[now]) continue;
                else{
                    printf("%c%d%c",now>n?'R':'C',now>n?now-n:now,i==len-1?'\n':' ');
                }
            }
            //printf("\n");
        }
    }    
}

转载于:https://www.cnblogs.com/liuzhanshan/p/6683015.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值