Kattis之旅——Divisible Subsequences

Given a sequence of positive integers, count all contiguous subsequences (sometimes called substrings, in contrast to subsequences, which may leave out elements) the sum of which is divisible by a given number. These subsequences may overlap. For example, the sequence (see sample input)
2, 1, 2, 1, 1, 2, 1, 2

contains six contiguous subsequences the sum of which is divisible by four: the first to eighth number, the second to fourth number, the second to seventh number, the third to fifth number, the fourth to sixth number, and the fifth to seventh number.

Input

The first line of the input consists of an integer c (1 <= c <= 200), the number of test cases. Then follow two lines per test case.
Each test case starts with a line consisting of two integers d (1 <= d <= 1 000 000) and n (1 <= n <= 50 000), the divisor of the sum of the subsequences and the length of the sequence, respectively. The second line of a test case contains the elements of the sequence, which are integers between 1 and 1 000 000 000, inclusively.

Output

For each test case, print a single line consisting of a single integer, the number of contiguous subsequences the sum of which is divisible by d.

 

Sample Input 1 Sample Output 1
2
7 3
1 2 3
4 8
2 1 2 1 1 2 1 2
0
6

错到心态爆炸,谁能告诉我WA的代码错在哪。。

WA代码:

//Asimple
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 1000010;
ll n, m, s, res, ans, len, T, k, num;int Hash[maxn];
void input() {
    scanf("%lld", &T);
    while( T -- ) {
        scanf("%lld%lld", &m, &n);
        memset(Hash, 0, sizeof(Hash));
        Hash[0] = 1;
        ll sum = 0;
        for(int i=0; i<n; i++) {
            scanf("%lld", &num);
            sum += num;
            sum %= m;
            Hash[sum]++;
        }
        ans = 0;
        for(int i=0; i<m; i++) {
            if( Hash[i]>0 )
                ans += Hash[i]*(Hash[i]-1)/2;
        }
        printf("%lld\n", ans);
    }
}

int main(){
    input();
    return 0;
}

 

AC代码:

 //Asimple
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 1000010;
ll n, m, s, res, ans, len, T, k, num;
ll Hash[maxn];
int a[maxn];void input() {
    scanf("%lld", &T);
    while( T -- ) {
        scanf("%lld%lld", &m, &n);
        memset(Hash, 0, sizeof(Hash));
        Hash[0] = 1;
        a[0] = 0;
        for(int i=1; i<=n; i++) {
            scanf("%lld", &num);
            a[i] = a[i-1]+num;
            a[i] %= m;
            Hash[a[i]]++;
        }
        ans = 0;
        for(int i=0; i<m; i++) {
            if( Hash[i]>0 )
                ans += Hash[i]*(Hash[i]-1)/2;
        }
        printf("%lld\n", ans);
    }
}

int main(){
    input();
    return 0;
}

谢谢大佬的AC代码:http://blog.csdn.net/luckyxiaoqiang/article/details/7900284

转载于:https://www.cnblogs.com/Asimple/p/6769778.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值