ZOJ 3410 Layton's Escape



Layton's Escape

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Professor Layton is a renowned archaeologist from London's Gressenheller University. He and his apprentice Luke has solved various mysteries in different places.

layton.jpg

Unfortunately, Layton and Luke are trapped in a pyramid now. To escape from this dangerous place, they need to pass N traps. For each trap, they can use Ti minutes to remove it. If they pass an unremoved trap, they will lose 1 HP. They have K HP at the beginning of the escape and they will die at 0 HP.

Of course, they don't want trigger any traps, but there is a monster chasing them. If they haven't pass the ith trap in Di minutes, the monster will catch and eat them. The time they start to escape is 0, and the time cost on running will be ignored. Please help Layton to escape from the pyramid with the minimal HP cost.

Input

There are multiple test cases (no more than 20).

For each test case, the first line contains two integers N and K (1 <= N <= 25000, 1 <= K <= 5000), then followed by N lines, the ith line contains two integers Ti and Di (0 <= Ti <= 10^9, 0 <= Di <= 10^9).

Output

For each test case, if they can escape from the pyramid, output the minimal HP cost, otherwise output -1.

Sample Input
3 2
40 60
60 90
80 120
2 1
30 120
60 40
Sample Output
1
-1
Author:  JIANG, Kai
Contest:  ZOJ Monthly, October 2010 

按d排序,如果有陷阱过不去,就去掉用时最长的那个陷阱。。。。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

struct node
{
    int t,d;
    bool operator<(const node a) const
    {
        return t<a.t;
    }
}p[26000];

bool cmp(node a,node  b)
{
    return a.d<b.d;
}

int main()
{
    int n,k;
while(cin>>n>>k)
{
    for(int i=0;i<n;i++)
    {
        int x,y;
        cin>>x>>y;
        p .t=x;   p.d=y;
    }
    sort(p,p+n,cmp);

    priority_queue<node> pq;

    int ddt=0;
    int ans=0;
    for(int i=0;i<n;i++)
    {
        pq.push(p );
        ddt+=p .t;
        if(ddt>p .d)
        {
            node x=pq.top();
            ddt-=x.t;
            pq.pop();
            ans++;
        }
    }

    ans=ans>=k? -1:ans;
    cout<<ans<<endl;
}

    return 0;
}


转载于:https://www.cnblogs.com/CKboss/p/3350917.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值