ZCMU 1010 Drawing Lines

Description

Little Johnny likes to draw a lot. A few days ago he painted lots of straight lines on his sheet of paper. Then he counted in how many zones the sheet of paper was split by these lines. He noticed that this number is not always the same. For instance, if he draws 2 lines, the sheet of paper could be split into 4, 3 or even 2 (if the lines are identical) zones. Since he is a very curious kid, he would like to know which is the maximum number of zones into which he can split the sheet of paper, if he draws N lines. The sheet of paper is to be considered a very large (=infinite) rectangle.

Input

The input file will contain an integer number:T(T<=1000);

then will contain T integers :N (0<=N<=65535).

Output

You should output: the maximum number of zones into which the sheet of paper can be split if Johnny draws N lines

Sample Input

2
0
1

Sample Output

1
2
——————————————————————————————————————————————————————————————
AC代码:
#include<stdio.h>

int main()
{
  int i,T;
  double N;
  scanf("%d",&T);
  for(i=1;i<=T;i++)
  {
    scanf("%lf",&N);
    printf("%.0f\n",(N*N+N+2)/2);
  }
  return 0;
}
——————————————————————————————————————————————————————————————

解题报告:
一条线最多分平面为2部分(2=1+1)
两条线最多分平面为4部分(4=1+1+2)
三条线最多分平面为7部分(7=1+1+2+3)
四条线最多分平面为11部分(11=1+1+2+3+4)

容易通过线段交点的个数来归纳得出更加一般的结论:
n条线最多分平面为(n^2+n+2)/2个部分((n^2+n+2)/2=1+1+2+3+4+....+n)

转载于:https://www.cnblogs.com/Reykjavik/archive/2013/01/17/2865114.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值