hdu 5059(模拟)

Help him

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2500    Accepted Submission(s): 518


Problem Description
As you know, when you want to hack someone's program, you must submit your test data. However sometimes you will submit invalid data, so we need a data checker to check your data. Now small W has prepared a problem for BC, but he is too busy to write the data checker. Please help him to write a data check which judges whether the input is an integer ranged from a to b (inclusive).
Note: a string represents a valid integer when it follows below rules.
1. When it represents a non-negative integer, it contains only digits without leading zeros.
2. When it represents a negative integer, it contains exact one negative sign ('-') followed by digits without leading zeros and there are no characters before '-'.
3. Otherwise it is not a valid integer.
 

 

Input
Multi test cases (about 100), every case occupies two lines, the first line contain a string which represents the input string, then second line contains a and b separated by space. Process to the end of file.

Length of string is no more than 100.
The string may contain any characters other than '\n','\r'.
-1000000000 ab1000000000
 

 

Output
For each case output "YES" (without quote) when the string is an integer ranged from a to b, otherwise output "NO" (without quote).
 

 

Sample Input
10 -100 100 1a0 -100 100
 

 

Sample Output
YES NO
 

 

Source
 
题意:判断一个字符串是否符合要求:
假设为正数,不能有前导0
假设为负数,最前面有 - 号,整数部分不能有前导0
这个串必须在 [a,b]之间
这个题坑的地方:判断 0 ,一定开longlong,我就被long long 坑死了。然后还有一点就是gets()读入。
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

char str[105];
int main()
{
    while(gets(str)){
        long long a,b;
        scanf("%lld%lld",&a,&b);
        getchar();
        if(strcmp(str,"0")==0){
            if(a<=0&&b>=0) printf("YES\n");
            else printf("NO\n");
            continue;
        }
        int len = strlen(str);
        if(len>11){
            printf("NO\n");
            continue;
        }
        int s = 0;
        bool flag = false,is_nag = false;
        if(str[0]=='-') {
            s++;
            is_nag = true;
        }
        long long sum = 0;
        if(str[s]=='0'||!isdigit(str[s])) flag = true;
        for(int i=s;i<len&&!flag;i++){
            if(isdigit(str[i])){
                sum = sum*10 + str[i]-'0';
            }else{
                flag = true;
            }
        }
        if(flag){
            printf("NO\n");
        }else{
            if(is_nag) sum = -sum;
            if(sum>=a&&sum<=b){
                printf("YES\n");
            }else{
                printf("NO\n");
            }
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/liyinggang/p/5652826.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值