hihocoder-Weekly228-Parentheses Matching

hihocoder-Weekly228-Parentheses Matching

 

题目1 : Parentheses Matching

时间限制:10000ms
单点时限:1000ms
内存限制:256MB

描述

Given a string of balanced parentheses output all the matching pairs.

输入

A string consisting of only parentheses '(' and ')'. The parentheses are balanced and the length of the string is no more than 100000.

输出

For each pair of matched parentheses output their positions in the string.

样例输入
(())()()
样例输出
1 4  
2 3  
5 6  
7 8

 

 

题解:

  需要注意的是: 如果在循环中使用 strlen(ch) 来判断长度,会导致TLE,可能是有些编译器对这方面的优化不够。

  更多的是: strlen(ch) 放在循环中也是一个不好的习惯,也是不安全的。 

 

#include <cstdio>  
#include <cstdlib>  
#include <cstring> 
const int MAXN = 100000 + 10; 

int main(){ 
    char ch[MAXN]; 
    int top = 0; 
    int stk[MAXN]; 
    int map[MAXN]; 

    scanf("%s", ch);  

    int len = strlen(ch); 

    for(int i=0; i<len; ++i)
    {
      if(ch[i] == '(')
      {
        stk[top++] = i; 
      }
      else if(ch[i] == ')')
      {
        --top; 
        map[stk[top]] = i;  
      }
    }
    for(int i=0; i<len; ++i)
    {
      if(ch[i] == '(')
      {
        printf("%d %d\n", i + 1, map[i] + 1);
      }
    } 
    return 0; 
} 

  

 

转载于:https://www.cnblogs.com/zhang-yd/p/9974870.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值