HDU 2674 N!Again (数论-水题)

N!Again

Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!
 

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 

Output
For each case, output N! mod 2009
 

Sample Input
 
  
4 5
 

Sample Output
 
  
24 120
 

Author
WhereIsHeroFrom
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2672  2668  2673  2669  2671 
 

题目大意:

求N!%2009的最大值,n最大10^9;


解题思路:

我靠,乍一看数据量挺大的,几秒后反应过来,n>=2009后还要计算个毛线。


解题代码:

#include <iostream>
#include <cstdio>
using namespace std;

int n;

int main(){
    while(scanf("%d",&n)!=EOF){
        if(n>=2009) printf("0\n");
        else{
            int ans=1;
            for(int i=2;i<=n;i++){
                ans=(ans*i)%2009;
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}





转载于:https://www.cnblogs.com/toyking/p/3893180.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值