poj1325

1.链接地址

https://vjudge.net/problem/POJ-1325

2.问题描述

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.

输入样例

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

输出样例

3

3.解题思路

建立一个二分图,左边代表A机器,有n个点,代表有n个模式
右边代表B机器,有m个点,代表有m个模式
现在对于每个作业,i,a,b都使左边a点指向右边b点即可

使用匈牙利算法直接匹配即可

4.算法实现源代码

#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
#include<cstdio>
using namespace std;

const int maxn=110;
int map[maxn][maxn];
int visit[maxn];
int link[maxn];
int n,m,k;
int sum;

int dfs(int x)
{
    for(int i=1;i<=m;i++)
    {
        if(!visit[i]&&map[x][i])
        {
            visit[i]=1;
            if(!link[i]||dfs(link[i]))
            {
                link[i]=x;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    while(~scanf("%d %d %d",&n,&m,&k)&&n)
    {
        memset(map,0,sizeof(map));
        for(int i=0;i<k;i++)
        {
            int a,x,y;
            scanf("%d%d%d",&a,&x,&y);
            map[x][y]=1;
        }
        sum=0;
        memset(link,0,sizeof(link));
        for(int i=1;i<=n;i++)
        {
            memset(visit,0,sizeof(visit));
            if(dfs(i)) sum++;
        }
        printf("%d\n",sum);
    }
}

 

转载于:https://www.cnblogs.com/KasenBob/p/11502649.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值