(STL大法) hdu 3283

The Next Permutation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 850    Accepted Submission(s): 597


Problem Description
For this problem, you will write a program that takes a (possibly long) string of decimal digits, and outputs the permutation of those decimal digits that has the next larger value (as a decimal number)
than the input number. For example:
123 -> 132
279134399742 -> 279134423799
It is possible that no permutation of the input digits has a larger value. For example, 987.
 

 

Input
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. Each data set is a single line that contains the data set number, followed by a space, followed by up to 80 decimal digits which is the input value.
 

 

Output
For each data set there is one line of output. If there is no larger permutation of the input digits, the output should be the data set number followed by a single space, followed by the string  BIGGEST. Ifthere is a solution, the output should be the data set number, a single space and the next larger
permutation of the input digits.
 

 

Sample Input
3 1 123 2 279134399742 3 987
 

 

Sample Output
1 132 2 279134423799 3 BIGGEST
 

 

Source
 
 
STL大法
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
#include<set>
#include<map>
using namespace std;
char s[81];
int main()
{
    int tt,x;
    scanf("%d",&tt);
    while(tt--)
    {
        scanf("%d %s",&x,s);
        int len=strlen(s);
        if(next_permutation(s,s+len))
            printf("%d %s\n",x,s);
        else
            printf("%d BIGGEST\n",x);
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/water-full/p/4485963.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值