HDU 5610 Baby Ming and Weight lifting

Baby Ming and Weight lifting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1365    Accepted Submission(s): 500

Problem Description
Baby Ming is fond of weight lifting. He has a barbell pole(the weight of which can be ignored) and two different kinds of barbell disks(the weight of which are respectively a and b), the amount of each one being infinite.
Baby Ming prepare to use this two kinds of barbell disks to make up a new one weighted C(the barbell must be balanced), he want to know how to do it.

 
Input
In the first line contains a single positive integer $T$, indicating number of test case.
For each test case:
There are three positive integer a, b, and c.
1<T<1000, 0 < a, b, C <= 1000, a != b
 
Output
For each test case, if the barbell weighted $C$ can’t be made up, print Impossible.
Otherwise, print two numbers to indicating the numbers of $a$ and $b$ barbell disks are needed. (If there are more than one answer, print the answer with minimum $a+b$)
 
Sample Input
2
1 2 6
1 4 5
 
Sample Output
2 2
Impossible
 
题目大意:2种类型的杠铃片(重量分别为a和b),每种杠铃片都有无限个。用这2种杠铃片组成重量为C的杠铃(杠铃必须平衡)。求a, b的数量(若如果有多种答案,输出a+b最小的方案)
思路:大神的方法太屌,982MS过
 
 
#include <stdio.h>
int main()
{
        int i, j, t, a, b, c, flag;
        scanf("%d", &t);
        while(t--)
        {
        scanf("%d%d%d", &a, &b, &c);
        if(c&1)
        {
        printf("Impossible\n");
        continue;
        }
        for(c /= 2,flag=0,i=0;!flag&&i<=2000;i++)//a+b的个数
                for(j=0;!flag&&j<=i;j++)//b的个数
                        if((i-j)*a+j*b==c&&(flag=1))
                        printf("%d %d\n", (i-j)<<1, j<<1);
        if(!flag) printf("Impossible\n");
        }
        return 0;
}

 

 



转载于:https://www.cnblogs.com/Noevon/p/5410780.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值