HDU5610 Baby Ming and Weight lifting 大水题

Baby Ming and Weight lifting


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1436    Accepted Submission(s): 524




Problem Description
Baby Ming is fond of weight lifting. He has a barbell pole(the weight of which can be ignored) and two different kinds of barbell disks(the weight of which are respectively a and b), the amount of each one being infinite.


Baby Ming prepare to use this two kinds of barbell disks to make up a new one weighted C(the barbell must be balanced), he want to know how to do it.




 


Input
In the first line contains a single positive integer T, indicating number of test case.


For each test case:


There are three positive integer a,b, and C.


1≤T≤1000,0<a,b,C≤1000,a≠b
 


Output
For each test case, if the barbell weighted C can’t be made up, print Impossible.


Otherwise, print two numbers to indicating the numbers of a and b barbell disks are needed. (If there are more than one answer, print the answer with minimum a+b)
 


Sample Input
2
1 2 6
1 4 5 
 


Sample Output
2 2
Impossible
 


Source
BestCoder Round #69 (div.2)
 


凑哑铃。。。





#include <iostream>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <iomanip>
#include <time.h>
#include <set>
#include <map>
#include <stack>
using namespace std;
typedef long long LL;
const int INF=0x7fffffff;
const int MAX_N=10000;

int T;
int a,b,c;
int main(){
    cin>>T;
    while(T--){
        cin>>a>>b>>c;
        if(c%2==1){
            cout<<"Impossible"<<endl;
            continue;
        }

        int flag=0;
        if(a>b){
            flag=1;
            swap(a,b);
        }
        int ans1,ans2,ss=0;
        for(int i=0;i<=1000;i++){
            int cur=i*a;
            if(cur>c/2)break;
            if((c/2-cur)%b==0){
                if(flag==1){
                    ans1=(c/2-cur)/b;
                    ans2=i;
                }
                else{
                    ans1=i;
                    ans2=(c/2-cur)/b;
                }
                ss=1;
                break;
            }
        }
        if(ss==1){
            cout<<2*ans1<<" "<<2*ans2<<endl;
        }
        else cout<<"Impossible"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值