hdu6441(2018ccpc网络赛-数论-费马大定理+勾股数)

Find Integer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2193    Accepted Submission(s): 753
Special Judge

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.

Input

one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

Output

print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);

else print two integers -1 -1 instead.

Sample Input

1 2 3

Sample Output

4 5

题意:

给出n和a求b, c满足a^n + b^n = c^n

ac:

简单的费马大定理+勾股数

2 * x + 1,2 * x* ( x+ 1 ),2 *x * ( x+ 1 ) + 1( x 为正整数 )

当 a 为奇数时,则 a = 2 * x + 1 ,解得 x 的值,则 b = 2 * x * ( x + 1 ),c = 2 * x * ( x + 1 ) + 1;

当 a 为偶数时,则 a 可能等于 p * ( 2 * x + 1 ),也可能等于 2 * x * ( x + 1 ) ,

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;

int main()
{
    long long a,b,c,n,x;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld%lld",&n,&a);
        if(n>2)
            printf("-1 -1\n");
        else if(n==2)
        {
            if(a%2==0)
            {
                x=a/2;
                printf("%lld %lld\n",x*x-1,x*x+1);
            }
            else {
                x=(a-1)/2;
                printf("%lld %lld\n",2*x+2*x*x,2*x+2*x*x+1);
            }
        }
        else if(n==1)
            printf("1 %lld\n",1+a);
        else if(n==0)
            printf("-1 -1\n");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/wangtao971115/p/10358220.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值