hdu 5912(迭代+gcd)

Fraction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 97    Accepted Submission(s): 64


Problem Description
Mr. Frog recently studied how to add two fractions up, and he came up with an evil idea to trouble you by asking you to calculate the result of the formula below:


As a talent, can you figure out the answer correctly?
 

 

Input
The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains only one integer n ( n8).

The second line contains n integers: a1,a2,an(1ai10).
The third line contains n integers: b1,b2,,bn(1bi10).
 

 

Output
For each case, print a line “Case #x: p q”, where x is the case number (starting from 1) and p/q indicates the answer.

You should promise that p/q is irreducible.
 

 

Sample Input
1 2 1 1 2 3
 

 

Sample Output
Case #1: 1 2
Hint
Here are the details for the first sample: 2/(1+3/1) = 1/2
 
题意:求图上的公式的结果.直接迭代求然后约分
#include <bits/stdc++.h>
using namespace std;
map<int ,int> value;
int a[10],b[10];
int gcd(int x,int y){
    return y==0?x:gcd(y,x%y);
}
int main()
{
    int tcase,t=1;
    scanf("%d",&tcase);
    while(tcase--){
        int n,res1,res2;
        scanf("%d",&n);
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        for(int i=1;i<=n;i++) scanf("%d",&b[i]);
        res1 = a[n],res2 = b[n];
        for(int i=n-1;i>=1;i--){
            int k = res1;
            res1 = a[i]*res1+res2;
            res2 = b[i]*k;
        }
        int d = gcd(res1,res2);
        printf("Case #%d: %d %d\n",t++,res2/d,res1/d);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/liyinggang/p/5931382.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值