杭电ACM2602-Bone Collector

http://acm.hdu.edu.cn/showproblem.php?pid=2602

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13503    Accepted Submission(s): 5299

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
 
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 
Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 
Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 
Sample Output
14
 
0-1背包问题优化
将前i件物品放入容量为v的背包中这个子问题,若只考虑第i件物品的策略(放或不放),那么就可以转化为一个只牵扯前i-1件物品的问题。如果不放第i件物品,那么问题就转化为i-1件物品放入容量为v的背包中,价值为f[i-1][v];如果放第i件物品,那么问题就转化为i-1件物品放入剩下的容量为v-c[i]的背包中,此时能获得的最大价值就是f[i-1][v-c[i]]再加上通过放入第i件物品获得的价值w[i]
View Code
#include"iostream"
#include"cstring"
using namespace std;
 int main()
 {
     int t,n,v,f[1001],vol[1001],val[1001];
     cin>>t;
     while(t--)
     {
         cin>>n>>v;
         for(int i=0;i<n;i++)
             cin>>val[i];
         for(int i=0;i<n;i++)
             cin>>vol[i];
         memset(f,0,sizeof(f));
         for(int i=0;i<n;i++)
             for(int j=v;j>=vol[i];j--)
                f[j]=f[j]<f[j-vol[i]]+val[i]?f[j-vol[i]]+val[i]:f[j];
         cout<<f[v]<<endl;
     }
     return 0;
 }

 

转载于:https://www.cnblogs.com/guojing80695195/archive/2012/08/08/2628304.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值