uva673-Parentheses Balance

  Parentheses Balance 

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

(a)
if it is the empty string
(b)
if A and B are correct, AB is correct,
(c)
if A is correct,  (A ) and  [A ] is correct.

Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input 

The file contains a positive integer  n  and a sequence of  n  strings of parentheses  ()  and  [] , one string a line.

Output 

A sequence of  Yes  or  No  on the output file.

Sample Input 

3
([])
(([()])))
([()[]()])()

Sample Output 

Yes
No
Yes

这是一道模拟题,注意空行的处理就可以

#include <iostream>
#include <stack>
#include <string>
#include <map>
using namespace std;

map<char, char> m;
stack<char> st1;
int main(void){
	string s;
	int num;
	int flag;

#ifndef ONLINE_JUDGE
	freopen("f:\\infile.txt", "r", stdin);
#endif
	
	m['('] = ')';
	m['['] = ']';
	cin >> num;
	cin.ignore(10, '\n');
	while(num--){
		getline(cin, s);

		flag = 0;
		while(st1.size())
			st1.pop();
		for(int i = 0; i < s.size(); i++){
			if((s[i] == '(') || (s[i] == '['))
				st1.push(s[i]);
			else if(st1.size() && (s[i] == m[st1.top()])){
					st1.pop();
			}
			else{
				flag = 1;
				break;
			}
		}
		if(flag == 1){
			cout << "No" << endl;
			continue;
		}
		if(!st1.size())
			cout << "Yes";
		else
			cout << "No";
//		if(num != 0)
		cout << endl;	
	}
	return 0;
}


转载于:https://www.cnblogs.com/ldxsuanfa/p/10721289.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值