JAVA中point类的构造函数_Java练习 SDUT-2670_3-1 Point类的构造函数

3-1 Point类的构造函数

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

通过本题目的练习可以掌握类的构造函数的定义;

设计一个点类Point,私有数据成员有x、y;公有成员函数有:无参数的构造函数Point(),带参数的构造函数Point(int,int);ShowPoint()输出点对象的信息

在主函数main()中调用相应成员函数,从键盘接收时间对象的x和y的值,并向显示器输出相应的值。

Input

输入2个整数,用一个空格间隔

Output

要求先输出默认的点值,再输出用户构造的点的值

点的格式为:一对圆括号内 x,y的值,中间用“,”间隔;

Sample Input

10 11

Sample Output

(0,0)

(10,11)

重构函数,关于输出有点迷,初始值在输入前后输出都可以。

import java.util.*;

public class Main {

public static void main(String[] args)

{

Scanner cin = new Scanner(System.in);

point a = new point();

a.show();

a = new point(cin.nextInt(),cin.nextInt());

a.show();

cin.close();

}

}

class point

{

private int x,y;

public point()

{

x = 0;

y = 0;

}

public point(int x,int y)

{

this.x = x;

this.y = y;

}

public void show()

{

System.out.printf("(%d,%d)\n",x,y);

}

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值