c#语言break语句用法,break 语句 - C# 参考 | Microsoft Docs

break(C# 参考)

07/20/2015

本文内容

break 语句将终止其所在位置的最接近封闭循环或 switch 语句。 控制权将传递给已终止语句后面的语句(若有)。

示例

在此示例中,条件语句包含一个应从 1 计数到 100 的计数器;但 break 语句在计数器计数到 4 后终止了循环。

class BreakTest

{

static void Main()

{

for (int i = 1; i <= 100; i++)

{

if (i == 5)

{

break;

}

Console.WriteLine(i);

}

// Keep the console open in debug mode.

Console.WriteLine("Press any key to exit.");

Console.ReadKey();

}

}

/*

Output:

1

2

3

4

*/

示例

本示例演示 break 在 switch 语句中的用法。

class Switch

{

static void Main()

{

Console.Write("Enter your selection (1, 2, or 3): ");

string s = Console.ReadLine();

int n = Int32.Parse(s);

switch (n)

{

case 1:

Console.WriteLine("Current value is 1");

break;

case 2:

Console.WriteLine("Current value is 2");

break;

case 3:

Console.WriteLine("Current value is 3");

break;

default:

Console.WriteLine("Sorry, invalid selection.");

break;

}

// Keep the console open in debug mode.

Console.WriteLine("Press any key to exit.");

Console.ReadKey();

}

}

/*

Sample Input: 1

Sample Output:

Enter your selection (1, 2, or 3): 1

Current value is 1

*/

如果输入 4,则输出为:

Enter your selection (1, 2, or 3): 4

Sorry, invalid selection.

示例

在此示例中,break 语句用于中断内层嵌套循环,并将控制权返回给外层循环。 控件在嵌套循环中仅向上返回一级__。

class BreakInNestedLoops

{

static void Main(string[] args)

{

int[] numbers = { 0, 1, 2, 3, 4, 5, 6, 7, 8, 9 };

char[] letters = { 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j' };

// Outer loop.

for (int i = 0; i < numbers.Length; i++)

{

Console.WriteLine($"num = {numbers[i]}");

// Inner loop.

for (int j = 0; j < letters.Length; j++)

{

if (j == i)

{

// Return control to outer loop.

break;

}

Console.Write($" {letters[j]} ");

}

Console.WriteLine();

}

// Keep the console open in debug mode.

Console.WriteLine("Press any key to exit.");

Console.ReadKey();

}

}

/*

* Output:

num = 0

num = 1

a

num = 2

a b

num = 3

a b c

num = 4

a b c d

num = 5

a b c d e

num = 6

a b c d e f

num = 7

a b c d e f g

num = 8

a b c d e f g h

num = 9

a b c d e f g h i

*/

示例

在本例中,break 语句仅用于在循环的每次迭代中脱离当前分支。 循环本身不受属于嵌套 switch 语句的 break 实例的影响。

class BreakFromSwitchInsideLoop

{

static void Main(string[] args)

{

// loop 1 to 3

for (int i = 1; i <= 3; i++)

{

switch(i)

{

case 1:

Console.WriteLine("Current value is 1");

break;

case 2:

Console.WriteLine("Current value is 2");

break;

case 3:

Console.WriteLine("Current value is 3");

break;

default:

Console.WriteLine("This shouldn't happen.");

break;

}

}

// Keep the console open in debug mode.

Console.WriteLine("Press any key to exit.");

Console.ReadKey();

}

}

/*

* Output:

Current value is 1

Current value is 2

Current value is 3

*/

C# 语言规范

有关详细信息,请参阅 C# 语言规范。 该语言规范是 C# 语法和用法的权威资料。

请参阅

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值