hdu1397(素数组和成偶数的个数 用 标记法)

Problem Description
Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.
 

 

Input
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.
 

 

Output
Each output line should contain an integer number. No other characters should appear in the output.
 

 

Sample Input
6 10 12 0
 

 

Sample Output
1 2 1
#include<iostream>
#include<cmath>
using namespace std;
int prime[800000];
int isprime(int a)//判断是否是素数
{
    int i;
    for (i=2;i<=sqrt(a*1.0)+0.5;i++)
    if(a%i==0)
    return 0;
    return 1;
}
void prime_b()//打素数表
{
    int i;
    for(i=2;i<=32768;i++)
    if(isprime(i))//i是素数记为1
    prime[i]=1;
    else  //不是记为0
    prime[i]=0;
}
int main()
{
    int n,p,k;
    
    prime_b();
    
    while(cin>>n&&n)
    {
        k=0;
        if(prime[n-2])//和2组和的数
        k++;
        for(p=3;p<=n/2;p+=2)
        if(prime[p]&&prime[n-p])
        k++;
        cout<<k<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值