POJ1218 HDU1337 ZOJ1350 UVALive2557 THE DRUNK JAILER

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28334 Accepted: 17574

Description

A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked.  
One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the  
hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He  
repeats this for n rounds, takes a final drink, and passes out.  
Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape.  
Given the number of cells, determine how many prisoners escape jail.

Input

The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n.  

Output

For each line, you must print out the number of prisoners that escape when the prison has n cells.  

Sample Input

2
5
100

Sample Output

2
10

Source


Regionals 2002 >> North America - Greater NY


问题链接POJ1218 HDU1337 ZOJ1350 UVALive2557 THE DRUNK JAILER

题意简述输入n,n为5-100间的一个数,代表有多少间牢房。刚开始所有房间打开,第1轮2的倍数的房间门翻转(打开的关上,关上的打开),第2轮3的倍数,第3轮4的倍数,......,第n-1轮n的倍数。求最后有几间牢房门是打开的。

问题分析:使用模拟法,模拟这个过程即可。好在计算规模不算大。

程序说明:(略)


参考链接:(略)


AC的C语言程序如下:

/* POJ1218 HDU1337 ZOJ1350 UVALive2557 THE DRUNK JAILER */

#include <stdio.h>
#include <memory.h>

#define MAXN 100

int cell[MAXN+1];

int main(void)
{
    int t, n, sum, i, j;

    scanf("%d", &t);
    while(t--) {
        scanf("%d", &n);

        memset(cell, 0, sizeof(cell));

        for(i=2; i<=n; i++)
            for(j=i; j<=n; j++)
                if (j%i == 0)
                    cell[j] = 1 - cell[j];

        sum = 0;
        for(i=1; i<=n; i++)
            if(cell[i] == 0)
                sum++;

        printf("%d\n",sum);
    }

    return 0;
}

还有一种大牛做的,直接计算的方法,其数学道理真的不懂。AC的C语言程序如下:

/* POJ1218 THE DRUNK JAILER */

#include <stdio.h>
#include <math.h>

int main(void)
{
    int t, n, ans;

    scanf("%d",&t);
    while(t--) {
        scanf("%d", &n);

        ans = (int)sqrt(n);

        printf("%d\n", ans);
    }

    return 0;
}



转载于:https://www.cnblogs.com/tigerisland/p/7564406.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值