6609 - Minimal Subarray Length

https://icpcarchive.ecs.baylor.edu/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=4620

 

 

You are given an integer sequence of length N and another value X. You have to find a contiguous
subsequence of the given sequence such that the sum is greater or equal to X. And you have to find
that segment with minimal length.
Input
First line of the input file contains T the number of test cases. Each test case starts with a line
containing 2 integers N (1 ≤ N ≤ 500000) and X (−109 ≤ X ≤ 109
). Next line contains N integers
denoting the elements of the sequence. These integers will be between −109
to 109
inclusive.
Output
For each test case output the minimum length of the sub array whose sum is greater or equal to X. If
there is no such array, output ‘-1’.
Sample Input
3
5 4
1 2 1 2 1
6 -2
-5 -6 -7 -8 -9 -10
5 3
-1 1 1 1 -1
Sample Output
3
-1
3

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;

const int N = 510000;
const int INF = 0x3fffffff;
typedef long long LL;
#define met(a,b) (memset(a,b,sizeof(a)))

struct node
{
    LL x;
    int Start;
} sum[N];

LL a[N];

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int n, i, Min=N, X, Start;
        LL x;

        met(a, 0);
        met(sum, 0);

        scanf("%d%lld", &n, &x);

        for(i=1; i<=n; i++)
            scanf("%lld", &a[i]);

        for(i=1; i<=n; i++)
        {
            if(sum[i-1].x<=0 || i==1)
            {
                sum[i].x = a[i];
                sum[i].Start = i;
            }
            else
            {
                sum[i].x = sum[i-1].x + a[i];
                sum[i].Start = sum[i-1].Start;
            }
            if(sum[i].x>=x)
            {
                Min = min(Min, i-sum[i].Start+1);
                X = sum[i].x, Start = sum[i].Start;
                while(X>=0 && Start<=i)
                {
                    X -= a[Start];
                    Start++;
                    if(X >= x)
                    {
                        sum[i].x = X;
                        sum[i].Start = Start;
                        Min = min(Min, i-Start+1);
                    }
                }
            }
        }

        printf("%d\n", Min!=N?Min:-1);
    }

    return 0;
}


/**

300
5 4
1 2 1 2 1
6 -2
-5 -6 -7 -8 -9 -10
5 3
-1 1 1 1 -1
8 6
1 1 1 1 1 2 3 4
6 5
4 -3 4 -1 2 2
6 6
-5 1 2 4 1 3
6 5
4 -3 4 -1 -2 2
6 5
-1 -1 -2 3 -2 5
4 5
3 -2 4 1
8 6
1 1 1 1 1 3 1 2
8 6
1 1 1 1 1 3 2 1
8 6
1 1 1 1 1 3 1 1


**/

 

转载于:https://www.cnblogs.com/YY56/p/5473135.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值