R1配置如下:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 199.99.1.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
serial restart-delay 0
frame-relay map ip 199.99.1.1 102 broadcast
frame-relay map ip 199.99.1.2 102 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 100
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 199.99.1.0 0.0.0.255 area 0
!
R2配置如下;
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 199.99.1.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
serial restart-delay 0
frame-relay map ip 199.99.1.1 201 broadcast
frame-relay map ip 199.99.1.2 201 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
ip address 199.99.2.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
serial restart-delay 0
frame-relay map ip 199.99.2.1 405 broadcast
frame-relay map ip 199.99.2.2 405 broadcast
no frame-relay inverse-arp
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 100
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 199.99.1.0 0.0.0.255 area 0
network 199.99.2.0 0.0.0.255 area 1
!

R3配置如下:
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address dhcp
duplex half
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
ip address 199.99.2.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
serial restart-delay 0
frame-relay map ip 199.99.2.1 504 broadcast
frame-relay map ip 199.99.2.2 504 broadcast
no frame-relay inverse-arp
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 100
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.0 0.0.0.255 area 1
network 199.99.2.0 0.0.0.255 area 1
! b.gif