HDOJ 2028 Lowest Common Multiple Plus(n个数的最小公倍数)

Problem Description
求n个数的最小公倍数。

Input
输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。

Output
为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。

Sample Input
2 4 6
3 2 5 7

Sample Output
12
70

这个题主要注意的就是怎么去求2个数的最小公倍数。
每次求2个数的最小公倍数,再用这个最小公倍数和下一个数求最小公倍数,以此类推。。。

import java.util.Scanner;

public class Main {
    public static void main(String args[]){
        Scanner sc = new Scanner(System.in);

        while(sc.hasNext()){
            int n = sc.nextInt();
            int res = sc.nextInt();
            while(n-->1){
                int a = sc.nextInt();
                res = Lcmm(res,a);
            }
            System.out.println(res);
        }


    }

    private static int Lcmm(int res, int a) {
        int m = res/gcd(res,a) *a;
        //System.out.println("m= "+m);
        return m;
    }

    private static int gcd(int res, int a) {
        int c = res%a;
        while(c!=0){
            res =a;
            a=c;
            c=res%a;
            //System.out.println("a");
        }
        return a;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值