UVa 102-Ecological Bin Packing

问题描述】

Bin packing, or the placement of objects of certain weights into different bins subject to certain constraints, is an historically interesting problem. Some bin packing problems are NP-complete but are amenable to dynamic programming solutions or to approximately optimal heuristic solutions. In this problem you will be solving a bin packing problem that deals with recycling glass.

Recycling glass requires that the glass be separated by color into one of three categories: brown glass, green glass, and clear glass. In this problem you will be given three recycling bins, each containing a specified number of brown, green and clear bottles. In order to be recycled, the bottles will need to be moved so that each bin contains bottles of only one color. The problem is to minimize the number of bottles that are moved. You may assume that the only problem is to minimize the number of movements between boxes. For the purposes of this problem, each bin has infinite capacity and the only constraint is moving the bottles so that each bin contains bottles of a single color. The total number of bottles will never exceed 2^31.

Input 

The input consists of a series of lines with each line containing 9 integers. The first three integers on a line represent the number of brown, green, and clear bottles (respectively) in bin number 1, the second three represent the number of brown, green and clear bottles (respectively) in bin number 2, and the last three integers represent the number of brown, green, and clear bottles (respectively) in bin number 3. For example, the line 10 15 20 30 12 8 15 8 31 indicates that there are 20 clear bottles in bin 1, 12 green bottles in bin 2, and 15 brown bottles in bin 3. Integers on a line will be separated by one or more spaces. Your program should process all lines in the input file.

Output 

For each line of input there will be one line of output indicating what color bottles go in what bin to minimize the number of bottle movements. You should also print the minimum number of bottle movements. The output should consist of a string of the three upper case characters 'G', 'B', 'C' (representing the colors green, brown, and clear) representing the color associated with each bin. The first character of the string represents the color associated with the first bin, the second character of the string represents the color associated with the second bin, and the third character represents the color associated with the third bin. The integer indicating the minimum number of bottle movements should follow the string. If more than one order of brown, green, and clear bins yields the minimum number of movements then the alphabetically first string representing a minimal configuration should be printed.

Sample Input 

1 2 3 4 5 6 7 8 9
5 10 5 20 10 5 10 20 10

Sample Output 

BCG 30
CBG 50


【解题思路

  暴力枚举,维护最小值即可。


【具体实现

#include <iostream>

using namespace std;

char type[6][4] = {
	"BCG", "BGC", "CBG",
	"CGB", "GBC", "GCB" };

int table[6][9] = {
	0, 1, 1, 1, 1, 0, 1, 0, 1,
	0, 1, 1, 1, 0, 1, 1, 1, 0,
	1, 1, 0, 0, 1, 1, 1, 0, 1,
	1, 1, 0, 1, 0, 1, 0, 1, 1,
	1, 0, 1, 0, 1, 1, 1, 1, 0,
	1, 0, 1, 1, 1, 0, 0, 1, 1 };

int data[9];

int main()
{
	while (cin>>data[0]) {
		int Min = 0, spa = 1;
		for (int i = 1; i < 9; ++i) {
			cin>>data[i];
			Min += data[i];
		}
		for (int i = 0; i < 6; ++i) {
			int sum = 0;
			for (int j = 0; j < 9; ++j)
				sum += data[j] * table[i][j];
			if (sum < Min) {
				Min = sum;
				spa = i;
			}
		}
		cout << type[spa] << " " << Min << endl;
	}
	return 0;
}


【额外补充

   英语不好只能借助某度翻译了。心塞。



转载于:https://my.oschina.net/CoderBleak/blog/670391

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值