HDU Hat's Fibonacci

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 268 Accepted Submission(s): 112
Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 
Input
Each line will contain an integers. Process to end of file.
 
Output
For each case, output the result in a line.
 
Sample Input
100
 
Sample Output
4203968145672990846840663646


Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 
用二维数组模拟大数加法,每一行表述一个数,每一行的一个元素可以代表n位数,这个可以根据自己的需要自己定义。
其他的就和正常的加法一样了,注意进位处理。
 
#include <iostream>
#include <stdio.h>
using namespace
std;
int
s[7500][670];
void
solve(){

    s[1][1] = 1;s[2][1] = 1;
    s[3][1] = 1;s[4][1] = 1;
    int
i,j,k=0;
    for
(i = 5;i<7500;i++)
    for
( j = 1;j<=670 ;j++)
    {

        k += s[i-1][j]+s[i-2][j]+s[i-3][j]+s[i-4][j];
        s[i][j] = k%10000;
        k = k/10000;
    }

    while
(k)
    {

        s[i][j++] = k%10000;
        k = k/10000;
    }
}

int
main()
{

    int
n,i,j;

    solve();
    while
(cin>>n)
    {

        for
(i = 670; i>=1;i--)
        if
(s[n][i]!=0)break;

        printf("%d",s[n][i]);
        for
(j = i-1;j>=1;j--)

        printf("%04d",s[n][j]);
        printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值