Hdoj 1005

原题链接

问题描述

A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).

输入描述

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

输出描述

For each test case, print the value of f(n) on a single line.

输入样例

1 1 3
1 2 10
0 0 0

输出样例

2
5

思路

暴力枚举,因为是除7,余数最多49个一组循环,枚举找到循环后,即可快速算出

代码

#include <iostream>
using namespace std;

int main()
{
    int a[50] = {1, 1};
    int x, y, n;
    ios::sync_with_stdio(false);
    while(cin >> x >> y >> n)
    {
        if(x * y * n == 0) break;
        for(int i = 2; i < 49; i++)
            a[i] = (x * a[i - 1] + y * a[i - 2]) % 7;
        cout << a[(n - 1) % 49] << endl;
    }
    return 0;
}

转载于:https://www.cnblogs.com/HackHarry/p/8289827.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值