HDU5479 Scaena Felix【堆栈+输入流】

Scaena Felix

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1041    Accepted Submission(s): 450

Problem Description
Given a parentheses sequence consist of '(' and ')', a modify can filp a parentheses, changing '(' to ')' or ')' to '('.

If we want every not empty <b>substring</b> of this parentheses sequence not to be "paren-matching", how many times at least to modify this parentheses sequence?

For example, "()","(())","()()" are "paren-matching" strings, but "((", ")(", "((()" are not.
Input
The first line of the input is a integer   T, meaning that there are   T  test cases.

Every test cases contains a parentheses sequence   S  only consists of '(' and ')'.

1|S|1,000.
Output
For every test case output the least number of modification.
Sample Input
 
  
3 () (((( (())
Sample Output
 
  
1 0 2
Source

问题链接HDU5479 Scaena Felix

问题简述参见上文。

问题分析

这个题就是求输入字符串中有多少括号是匹配的。

这类匹配问题看似堆栈问题,是需要堆栈的概念的,即遇到左括号则进栈遇到右括号与栈中的括号匹配一下。

然而,实际上没有必要用堆栈,计数一下就好了。

程序说明:按字符流读入数据进行处理是最佳选择,使用缓存那是浮云。

题记:(略)

参考链接:(略)


AC的C语言程序如下:

/* HDU5479 Scaena Felix */

#include <stdio.h>

int main(void)
{
    int t;
    char c;

    scanf("%d", &t);
    getchar();
    while(t--) {
        int left = 0, ans = 0;

        while((c = getchar()) != '\n') {
            if(c == '(')
                left++;
            else if(c == ')') {
                if(left > 0) {
                    left--;
                    ans++;
                }
            }
        }

        printf("%d\n", ans);
    }

    return 0;
}




转载于:https://www.cnblogs.com/tigerisland/p/7563581.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值