ZOJ 1202 Divide and Count

Divide and Count
http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=202

Time Limit: 2 Seconds      Memory Limit: 65536 KB

  Jack has several beautiful diamonds, each of them is unique thus precious. To keep them safe, he wants to divide and store them in different locations. First, he has bought some coffers. These boxes are identical except that their capacities (the number of the diamonds that a box can contain) may diverse. Before he puts his diamonds in, he wants to figure out how many different ways he can store these diamonds into the coffers. He recruits you, a young programmer from Zhejiang University, to give him the answer.

Input:
The input consists of several test cases. Each test case begins with a positive integer N, which indicates the number of the coffers Jack has bought. Then the following N integers are the capacities of each box. The total number of the diamonds Jack has equals to the sum of the capacities of all the coffers.

All the integers given are no greater than 12, you can be assured that a result always fits into a 32-bit integer.

Output:
For every test case, print out an integer representing the number of the different ways Jack can store his diamonds. Each integer is to be printed on a single line.

Sample input:

2
3 3
3
1 2 3


Sample output:

10
60

题意:
n个箱子,每个箱子能容纳ai个钻石,求m个不同的钻石全放到这些箱子里的方案数
两个箱子如果容积相同,那么认为他们是一模一样的
m=Σ ai

假设k个箱子分别有 s1、s2、s3 个相同的
C(tot,ai)*C(tot-a[1],a[2])*C(tot-a[1]-a[2],a[3])*……
ans=---------------------------------------------------
s1!*s2!*s3!

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[13],pre[13],rest[13],repeat[13];
int sum[150];
long long ans;
long long pow(long long a,long long b)
{
    long long r=1;
    while(b)
    {
        if(b&1) r*=a;
        b>>=1; a*=a;
    }
    return r;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(repeat,0,sizeof(repeat)); 
        memset(sum,0,sizeof(sum));
        for(int i=1;i<=n;i++) scanf("%d",&a[i]),repeat[a[i]]++;
        sort(a+1,a+n+1);
        for(int i=1;i<=n;i++) pre[i]=pre[i-1]+a[i];
        for(int i=1;i<=n;i++) rest[i]=pre[n]-pre[i-1];
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=rest[i];j++) sum[j]++;
            for(int j=1;j<=a[i];j++) sum[j]--;
            for(int j=1;j<=rest[i]-a[i];j++) sum[j]--;
            if(a[i]!=a[i+1] || i==n) 
            for(int j=1;j<=repeat[a[i]];j++) sum[j]--; 
        }
        ans=1;
        for(int i=2;i<=144;i++) 
         if(!sum[i]) continue;
         else if(sum[i]>0) ans=ans*pow(i,sum[i]);
        for(int i=2;i<=144;i++)
         if(sum[i]<0) ans=ans/pow(i,-sum[i]);
        printf("%lld\n",ans);
     }
}

 

转载于:https://www.cnblogs.com/TheRoadToTheGold/p/7353590.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值