POJ Girls and Boys (最大独立点集)

                                                            Girls and Boys
Time Limit: 5000MS Memory Limit: 10000K
Total Submissions: 12192 Accepted: 5454

Description

In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.

Input

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.

Output

For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2
【分析】给出一些有关系的男女们,问最多有多少人之间没有关系。那就是求最大独立点集了,最大独立点集==顶点总数-匹配数。
由于此题我是两两匹配了两次,所以除以二。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <queue>
#include <vector>
#define inf 0x7fffffff
#define met(a,b) memset(a,b,sizeof a)
typedef long long ll;
using namespace std;
const int N = 1005;
const int M = 25005;
int read() {
    int x=0,f=1;
    char c=getchar();
    while(c<'0'||c>'9') {
        if(c=='-')f=-1;
        c=getchar();
    }
    while(c>='0'&&c<='9') {
        x=x*10+c-'0';
        c=getchar();
    }
    return x*f;
}
int n,k,cnt;
int mp[N][N],vis[N],link[N];
int head[N],x[N],y[N];
struct man
{
    int to,next;
}edg[M];
void init()
{
    met(head,-1);met(x,0);met(edg,0);met(y,0);cnt=0;
}
void add(int u,int v)
{
    edg[cnt].to=v;edg[cnt].next=head[u];head[u]=cnt++;
}
bool dfs(int u) {
    for(int i=head[u];i!=-1;i=edg[i].next) {
        int v=edg[i].to;
        if(!vis[v]) {
            vis[v]=1;
            if(!y[v]||dfs(y[v])) {
                x[u]=v;
                y[v]=u;
                return true;
            }
        }
    }
    return false;
}
void MaxMatch() {
    int ans=0;
    for(int i=0; i<n; i++) {
        if(!x[i]) {
            met(vis,0);
            if(dfs(i))ans++;
        }
    }
    //printf("ans=%d\n",ans);
    printf("%d\n",n-ans/2);
}
int main()
{
    while(~scanf("%d\n",&n)){
        init();
        int u,nn,v;
        for(int i=0;i<n;i++){
            scanf("%d: (%d)",&u,&nn);
            for(int j=0;j<nn;j++){
                scanf("%d",&v);
                add(i,v);
            }
        }
        MaxMatch();
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/jianrenfang/p/5935024.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值