poj1466——Girls and Boys(最大独立点集)

Description

In the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.
Input

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 …
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.
Output

For each given data set, the program should write to standard output a line containing the result.
Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0
Sample Output

5
2

大意为学校里两个异性之间可能有罗曼史,现在要找出一群人他们之间没有罗曼史,求这个人数的最大值。明显的求最大独立集的问题,但由于不知道每个人的性别,所以二分图的两个点集都是所有人n,这样求出的最大匹配是真正的最大匹配的两倍,答案就是n-最大匹配/2

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <vector>
#include <iostream>
#include <set>
#include <cstring>
#include <string>
#define MAXN 510
#define inf 0xffffffff
using namespace std;
int map[MAXN][MAXN],vis[MAXN],pre[MAXN];
int n;
int find(int cur)
{
    for(int i=0; i<n; ++i)
    {
        if(!vis[i]&&map[cur][i])
        {
            vis[i] = true;
            if(pre[i] == 0 || find(pre[i]))
            {
                pre[i] = cur;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int m,x,y;
    while(~scanf("%d",&n))
    {
        getchar();
        memset(map,0,sizeof(map));
        memset(pre,0,sizeof(pre));
        for(int i=0; i<n; ++i)
        {
            scanf("%d: (%d)",&x,&m);
            while(m--)
            {
                scanf("%d",&y);
                map[x][y]=1;
            }
        }
        int ans=0;
        for(int i=0; i<=n; ++i)
        {
            memset(vis,0,sizeof(vis));
            if(find(i))
                ans++;
        }
        printf("%d\n",n-ans/2);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值