369 - Combinations

Combinations 

Computing the exact number of ways that N things can be taken M at a time can be a great challenge when N and/or M become very large. Challenges are the stuff of contests. Therefore, you are to make just such a computation given the following:

 

 

GIVEN:

displaymath41

 

Compute the EXACT value of:

 

displaymath43

 

You may assume that the final value of C will fit in a 32-bit Pascal LongInt or a C long.

 

For the record, the exact value of 100! is:

 

     93,326,215,443,944,152,681,699,238,856,266,700,490,715,968,264,381,621,
        468,592,963,895,217,599,993,229,915,608,941,463,976,156,518,286,253,
        697,920,827,223,758,251,185,210,916,864,000,000,000,000,000,000,000,000

 

Input and Output

The input to this program will be one or more lines each containing zero or more leading spaces, a value for N, one or more spaces, and a value for M. The last line of the input file will contain a dummy N, M pair with both values equal to zero. Your program should terminate when this line is read.

 

The output from this program should be in the form:

 

 

N things taken M at a time is C exactly.

 

Sample Input

 

     100  6
      20  5
      18  6
       0  0

 

Sample Output

 

100 things taken 6 at a time is 1192052400 exactly.
20 things taken 5 at a time is 15504 exactly.
18 things taken 6 at a time is 18564 exactly.
#include"stdio.h"
double fun1(int a)            
{ int i;
  double s=1;
  i=a;
  while(i)
  { s*=i;
    i--; 
          }
  return s;        
     }
double fun2(int c,int d)    
{ int j;
  double s=1;
  for(j=d+1;j<=c;j++)
  s*=j;
  return s;
     }     
int main()
{ int m,n;
  double c,s1,s2;
  while(1)
  {scanf("%d  %d",&n,&m);  
   if(n==0&&m==0)
   break;
   s1=fun1(n-m);//调用函数计算n-m的累乘;
   s2=fun2(n,m);//调用函数计算m到n的累乘;
   c=s2/s1;
   printf("%d things taken %d at a time is %.0lf exactly.\n",n,m,c);
}
return 0;
}
 
 

 

 

转载于:https://www.cnblogs.com/www-xzpboke-com/archive/2013/02/22/2922876.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值