poj2054

Color a Tree
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5832 Accepted: 1930

Description

Bob is very interested in the data structure of a tree. A tree is a directed graph in which a special node is singled out, called the "root" of the tree, and there is a unique path from the root to each of the other nodes. 

Bob intends to color all the nodes of a tree with a pen. A tree has N nodes, these nodes are numbered 1, 2, ..., N. Suppose coloring a node takes 1 unit of time, and after finishing coloring one node, he is allowed to color another. Additionally, he is allowed to color a node only when its father node has been colored. Obviously, Bob is only allowed to color the root in the first try. 

Each node has a "coloring cost factor", Ci. The coloring cost of each node depends both on Ci and the time at which Bob finishes the coloring of this node. At the beginning, the time is set to 0. If the finishing time of coloring node i is Fi, then the coloring cost of node i is Ci * Fi. 

For example, a tree with five nodes is shown in Figure-1. The coloring cost factors of each node are 1, 2, 1, 2 and 4. Bob can color the tree in the order 1, 3, 5, 2, 4, with the minimum total coloring cost of 33. 

Given a tree and the coloring cost factor of each node, please help Bob to find the minimum possible total coloring cost for coloring all the nodes.

Input

The input consists of several test cases. The first line of each case contains two integers N and R (1 <= N <= 1000, 1 <= R <= N), where N is the number of nodes in the tree and R is the node number of the root node. The second line contains N integers, the i-th of which is Ci (1 <= Ci <= 500), the coloring cost factor of node i. Each of the next N-1 lines contains two space-separated node numbers V1 and V2, which are the endpoints of an edge in the tree, denoting that V1 is the father node of V2. No edge will be listed twice, and all edges will be listed. 

A test case of N = 0 and R = 0 indicates the end of input, and should not be processed. 

Output

For each test case, output a line containing the minimum total coloring cost required for Bob to color all the nodes.

Sample Input

5 1
1 2 1 2 4
1 2
1 3
2 4
3 5
0 0

Sample Output

33

Source

 
这题真心实力不够,看了ac代码都看了很久。。。
 
Problem: 2054		User: BUPT_ERIC
Memory: 196K		Time: 172MS
Language: C++		Result: Accepted
Source Code
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int MAXN=1010;
typedef struct
{
    int cost;
    int num;
    int ans;
}Node;
int n,root;
int parent[MAXN];
bool isTraversed[MAXN];
Node tree[MAXN];

void createSet()
{
    for(int i=1; i<=n; i++)
    {
        parent[i]=i;
    }
}

int find(int x)
{
    if(x!=parent[x] && isTraversed[parent[x]])
    {
        parent[x]=find(parent[x]);
    }
    return parent[x];
}

void unionSet(int x, int y)
{
    parent[y]=x;
}

int main()
{
    int v1,v2;
    double maxCost;
    int maxNode,maxNodeParent;

    while(scanf("%d%d",&n,&root)!=EOF && n+root)
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&tree[i].cost);
            tree[i].num=1;
            tree[i].ans=tree[i].cost;
        }
        createSet();
        memset(isTraversed,0,sizeof(isTraversed));
        for(int i=1; i<=n-1; i++)
        {
            scanf("%d %d",&v1, &v2);
            unionSet(v1,v2);
        }
        for(int i=1; i<=n-1; i++)
        {
            maxCost=0.0;
            int j;
            for(j=1;j<=n;j++)
            {
                if(!isTraversed[j] && j!=root)
                {
                    if(tree[j].cost*1.0/tree[j].num > maxCost)
                    {
                        maxCost=tree[j].cost*1.0/tree[j].num;
                        maxNode=j;
                    }
                }
             }
            isTraversed[maxNode]=true;
            maxNodeParent=find(maxNode);
            tree[maxNodeParent].ans+=tree[maxNode].cost*tree[maxNodeParent].num+tree[maxNode].ans;
            tree[maxNodeParent].num+=tree[maxNode].num;
            tree[maxNodeParent].cost+=tree[maxNode].cost;
        }
        printf("%d\n",tree[root].ans);
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/eric-blog/archive/2012/05/02/2479856.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值