Transportation poj1040

Ruratania is just entering capitalism and is establishing new enterprising activities in many fields in- cluding transport. The transportation company TransRuratania is starting a new express train from city A to city B with several stops in the stations on the way. The stations are successively numbered, city A station has number 0, city B station number m. The company runs an experiment in order to improve passenger transportation capacity and thus to increase its earnings. The train has a maximum capacity n passengers. The price of the train ticket is equal to the number of stops (stations) between the starting station and the destination station (including the destination station). Before the train starts its route from the city A, ticket orders are collected from all onroute stations. The ticket order from the station S means all reservations of tickets from S to a fixed destination station. In case the company cannot accept all orders because of the passenger capacity limitations, its rejection policy is that it either completely accept or completely reject single orders from single stations. 

Write a program which for the given list of orders from single stations on the way from A to B determines the biggest possible total earning of the TransRuratania company. The earning from one accepted order is the product of the number of passengers included in the order and the price of their train tickets. The total earning is the sum of the earnings from all accepted orders. 

Input

The input file is divided into blocks. The first line in each block contains three integers: passenger capacity n of the train, the number of the city B station and the number of ticket orders from all stations. The next lines contain the ticket orders. Each ticket order consists of three integers: starting station, destination station, number of passengers. In one block there can be maximum 22 orders. The number of the city B station will be at most 7. The block where all three numbers in the first line are equal to zero denotes the end of the input file.

Output

The output file consists of lines corresponding to the blocks of the input file except the terminating block. Each such line contains the biggest possible total earning.

Sample Input

10 3 4
0 2 1
1 3 5
1 2 7
2 3 10
10 5 4
3 5 10
2 4 9
0 2 5
2 5 8
0 0 0

Sample Output

19
34


(1)题意:火车运输,n个车站编号0-(n-1)。之间有非常多订单,问你,最大收益是多少?火车的载客量一定,车上的人不能超过这个数,先给你3个数。火车载客量m、车站数n、订单数p。然后p行数据,每行3个数。分别代表订单的起点、终点和人数。

(2)解法:先对订单进行排序,按起点站先后排,若一样,按终点排,然后对订单进行深度搜索。剪枝:遇到人数超过载客量的时候,就返回。



#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;
struct Rac{
    int start;
    int end1;
    int num;
}p[30];


int lode,station,order;
int maxmoney;
int people[30]={0}; //表示到i站的人数,。people[2]表示站1到站二的人数


void DFS(int ding,int money) //第几订单。钱。
{
    if(ding==order)
    {
        maxmoney=max(maxmoney,money);
        return ;
    }
    int i,j,flag=1;
    for(i=p[ding].start+1;i<=p[ding].end1;i++) //推断人人数是否超了
    {
        if(people[i]+p[ding].num>lode)
        {
            flag=0;
            break;
        }
    }


    if(flag==1)  //第ding条订单符合条件~~
    {
        for(i=p[ding].start+1;i<=p[ding].end1;i++) people[i]=people[i]+p[ding].num;  //start到end站都加上该订单人数
        DFS(ding+1,money+(p[ding].end1-p[ding].start)*p[ding].num);
        for(i=p[ding].start+1;i<=p[ding].end1;i++) people[i]=people[i]-p[ding].num;//恢复
    }


    DFS(ding+1,money); //不要该订单;
}
bool cmp(struct Rac a,struct Rac b)
{
    if(a.start!=b.start) return a.start<b.start;
    else return a.end1<b.end1;
}
int main()
{
    //freopen("test.txt","r",stdin);
    while(scanf("%d %d %d",&lode,&station,&order),lode!=0||station!=0||order!=0)
    {
        int i;
        for(i=0;i<order;i++) scanf("%d %d %d",&p[i].start,&p[i].end1,&p[i].num);
        sort(p,p+order,cmp);
       // for(i=0;i<order;i++) printf("%d %d %d\n",p[i].start,p[i].end1,p[i].num);


        memset(people,0,sizeof(people));
        maxmoney=0;
        DFS(0,0);
        printf("%d\n",maxmoney);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值