HZAU1098: Yifan and War3(区间dp)

1098: Yifan and War3

Time Limit: 3 Sec   Memory Limit: 128 MB
Submit: 622   Solved: 20
[ Submit][ Status][ Web Board]

Description

As we all know, There is a hero called Priestess of the Moon(POM), which has a passive ability named  Trueshot Aura . It can add other units some ranged attacks . Fanfan love the Human very much, and he will battle with a Night Elf everyday , because he thinks the Night Elf can’t attack his tower easily .But today , he met a Night Elf player , who use POM as his first hero, and had lots of Archers . Fanfan use the Mountain King to kill the Archers ,and don’t know how many health he need to kill all the Archers .Could you help him ?
        To make the problem simple , we assume that all the Archers stand in a line , they have different attacks , if Fanfan kills the ith Archer , the (i+1)th and the (i-1)th Archer will help to attack Fanan by their own attacks . There are N Archers , and Fanfan wants to know the least damage he will get to kill all the Archers .

Input

First line contains an integer N (0<N<200), means there are N Archers .
Then the next line contains N integers ai(0<ai<100000) means that the ith Archers have ai attacks . 

Output

An integer means the least damage Fanfan will get.

Sample Input

3
10 100 10

Sample Output

150

HINT

Yifan first kill the second Archer , get 100+10+10 demages , and then kill the first one ,get 10+10 demages and finally kill the third one and get 10 demages so , he get 150 demage

看了其他人的思路整理出来。相似题目:POJ1651:Multiplication Puzzle
# include <stdio.h>
# include <string.h>
int min(int a, int b)
{
    return a<b?a:b;
}
int main()
{
    int dp[202][202] = {0}, a[202], i, n, k, len, imin, imin1, imin2;
    while(scanf("%d",&n) != EOF)
    {
        memset(a, 0, sizeof(a));
        memset(dp, 0, sizeof(dp));
        for(i=1; i<=n; ++i)
            scanf("%d",&a[i]);
        a[0] = a[n+1] = 0;
        for(i=1; i<=n; ++i)
            dp[i][i] = a[i-1]+a[i]+a[i+1];
        for(len=1; len<=n; ++len)
        {
            for(i=1; i+len<=n; ++i)
            {

            //相当于枚举最后消去的点
                imin1 = dp[i+1][i+len]+a[i-1]+a[i+len+1]+a[i]; //为第一个点的情况
                imin2 = dp[i][i+len-1] + a[i+len]+a[i-1]+a[i+len+1];//为最后一个点的情况
                imin = min(imin1, imin2);
                for(k=i+1; k<i+len; ++k)//为点在中间的情况
                    imin = min(imin, dp[i][k-1]+dp[k+1][i+len]+a[k]+a[i-1]+a[i+len+1]);
                dp[i][i+len] = imin;
            }
        }
        printf("%d\n",dp[1][n]);
    }
    return 0;
}

转载于:https://www.cnblogs.com/junior19/p/6730118.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值