poj1742

 

Coins
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 33998 Accepted: 11554

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

Source

 

poj1742 动态规划 经典多重背包

有n种不同面值的硬币,面值各为A1,A2,A3。。AN,数量各为C1,C2,C3,,,,,CN。给定数m,问这些硬币能组成小于等于m的数中的哪些数,输出这些数的数目。

其实这个vn算法的编码很简单,关键是如何证明这种贪心是正确的,这个比较复杂,,我还在理解中!!!!!!!!

---用单调队列优化的DP已超出了NOIP的范围,

#include<cstdio>
#include<cstring>
using namespace std;
int n,m,ans,w[105],v[105],d[100005],s[100005];
int main()
{
    while(scanf("%d%d",&n,&m)==2&&n&&m){
        int i,j;ans=0;
        for(i=0;i<n;i++) scanf("%d",w+i);
        for(i=0;i<n;i++) scanf("%d",v+i);
        memset(d,0,sizeof(d));
        for(d[i=0]=1;i<n;i++){
            for(j=0;j<=m;j++) s[j]=0;    
            for(j=w[i];j<=m;j++)
                if(!d[j]&&d[j-w[i]]&&s[j-w[i]]<v[i])
                    d[j]=1,s[j]=s[j-w[i]]+1;
        }
        for(i=1;i<=m;i++)
            if(d[i])
                ans++;
        printf("%d\n",ans);
    }
    return 0;
}

 

#include<cstdio>
int n,m,res;
int use[100005],c[105],f[100005];
int main()
{
    f[0]=1;
    while(scanf("%d%d",&n,&m)==2&&n&&m){
        res=0;
        for(int i=1;i<=m;i++) f[i]=0;
        for(int i=0;i<n;i++) scanf("%d",&c[i]);
        for(int i=0,s;i<n;i++){
            for(int j=0;j<=m;j++) use[j]=0;
            scanf("%d",&s);
            for(int j=c[i];j<=m;j++){
                if(!f[j]&&f[j-c[i]]&&use[j-c[i]]<s){//贪心过程
                    use[j]=use[j-c[i]]+1;
                    f[j]=1;
                    res++;
                }
            }
        }
        printf("%d\n",res);
    }
    return 0;
}

 

对比上下两张AC图

太想节省空间,空间没节省了,时间还更长了。

读入完成再处理比边读边处理快!!!

转载于:https://www.cnblogs.com/shenben/p/5616973.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值