Backward Digit Sums(暴力)

Backward Digit Sums
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5664 Accepted: 3280

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:  
    3   1   2   4
       4   3   6
         7   9
          16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 
Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample:  
There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.
题解:让根据结果16找开始的序列3 1 2 4
3   1   2   4
    4  3  6
      7  9
      16
刚看到这个题就有个想法暴力所有全排列找答案,不过直接被我排除了,首先麻烦而且还可能超时,PS(n< =10超时个鬼啊);然后我就找到了一个错误的规律:
ad=((n-1)*n*(n+1)/2-sum)/(n-2);
首末两项之和确定。。。暂且不知道对错,被我调试了N长时间后,我放弃了,直接暴力就A了。。。
#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
#define mem(x,y) memset(x,y,sizeof(x))
#define SI(x) scanf("%d",&x)
#define PI(x) printf("%d",x)
#define P_ printf(" ")
const int MAXN=1010;
int ans[MAXN];
int vis[MAXN];
int N,M;
int flot;
int a[15];
void dfs(int num){
    if(flot)return;
    if(num==N){
        int sum=0,temp=N;
        for(int i=0;i<N;i++)a[i]=ans[i];
        while(temp>1){
            for(int i=0;i<temp-1;i++){
                a[i]+=a[i+1];
            }
            temp--;
        }
        sum=a[0];
        if(sum==M){
            for(int i=0;i<N;i++){
                if(i)P_;
                printf("%d",ans[i]);
            }
            puts("");
            flot=1;
        }
        return ;
    }
    for(int i=0;i<N;i++){
        if(vis[i+1])continue;
        ans[num]=i+1;
        vis[i+1]=1;
        dfs(num+1);
        vis[i+1]=0;
    }
}
int main(){
     while(~scanf("%d%d",&N,&M)){
         if(N==1){
             puts("1");continue;
         }
         mem(vis,0);
         flot=0;
         dfs(0);
     }
    return 0;
} 

 另一种写法:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int sum;
bool cal(int (*a)[15], int N){
    
    
    for(int i = 2; i <= N; i++){
        for(int j = 1; j <= N - i + 1; j++){
            a[i][j] = a[i - 1][j] + a[i - 1][j + 1];
        }
    }
    if(a[N][1] == sum)
        return true;
    else
        return false;
    
}
int main(){
    int N;
    int a[15][15];
    
    while(~scanf("%d%d", &N, &sum)){
        for(int i = 1; i <= N; i++){
            a[1][i] = i;
        }
        
        do{
            if(cal(a, N)){
                for(int i = 1; i <= N; i++){
                    printf("%d", a[1][i]);
                    if(i != N){
                        printf(" ");
                    }else{
                        printf("\n");
                    }
                }
                break;
            }
        }while(next_permutation(a[1] + 1, a[1] + N + 1));
    }
    return 0;
}

 

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
该资源内项目源码是个人的课程设计、毕业设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。 该资源内项目源码是个人的课程设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值