hdu 5742 It's All In The Mind 水题

It's All In The Mind

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=5742

Description

Professor Zhang has a number sequence a1,a2,...,an. However, the sequence is not complete and some elements are missing. Fortunately, Professor Zhang remembers some properties of the sequence:

  1. For every i∈{1,2,...,n}, 0≤ai≤100.
  2. The sequence is non-increasing, i.e. a1≥a2≥...≥an.
  3. The sum of all elements in the sequence is not zero.

Professor Zhang wants to know the maximum value of a1+a2∑ni=1ai among all the possible sequences.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first contains two integers n and m (2≤n≤100,0≤m≤n) -- the length of the sequence and the number of known elements.

In the next m lines, each contains two integers xi and yi (1≤xi≤n,0≤yi≤100,xi<xi+1,yi≥yi+1), indicating that axi=yi.

Output

For each test case, output the answer as an irreducible fraction "p/q", where p, q are integers, q>0.

Sample Input

2
2 0
3 1
3 1

Sample Output

1/1
200/201

Hint

题意

你有n个数,现在给你规定一些数的取值。

然后你要给其他没有赋值的数赋值,使得这个序列是单调不增的序列。

并且(a1+a2)/sigma(a)最大,输出这个值。

题解:

贪心就好了,a1,a2取得越大越好,剩下的数取得越小越好。

先左右扫一下,确定每个数的取值范围,然后再扫一遍贪心就行了。

代码

#include<bits/stdc++.h>
using namespace std;
const int maxn = 103;
int a[maxn];
int gcd(int aa,int bb){
    if(bb==0)return aa;
    return gcd(bb,aa%bb);
}
int Ma[maxn],Mi[maxn];
void solve(){
    memset(a,-1,sizeof(a));
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=0;i<=n+1;i++){
        Ma[i]=100;
        Mi[i]=0;
    }
    for(int i=1;i<=m;i++){
        int x,y;
        scanf("%d%d",&x,&y);
        Ma[x]=y;
        Mi[x]=y;
    }

    for(int i=1;i<=n;i++)
        Ma[i]=min(Ma[i],Ma[i-1]);

    for(int i=n;i>=1;i--)
        Mi[i]=max(Mi[i],Mi[i+1]);

    long long up = 0;
    long long down = 0;

    for(int i=1;i<=n;i++){
        if(i<=2)a[i]=Ma[i];
        else a[i]=Mi[i];
        down+=a[i];
    }
    up = a[1]+a[2];
    if(down==0)down=1;
    int g = gcd(up,down);
    printf("%I64d/%I64d\n",up/g,down/g);
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--)solve();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值