HDU 5742 It's All In The Mind (水题)

题目链接:HDU 5742


题面:

It's All In The Mind

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 483    Accepted Submission(s): 216


Problem Description
Professor Zhang has a number sequence a1,a2,...,an . However, the sequence is not complete and some elements are missing. Fortunately, Professor Zhang remembers some properties of the sequence:

1. For every i{1,2,...,n} , 0ai100 .
2. The sequence is non-increasing, i.e. a1a2...an .
3. The sum of all elements in the sequence is not zero.

Professor Zhang wants to know the maximum value of a1+a2ni=1ai among all the possible sequences.
 

Input
There are multiple test cases. The first line of input contains an integer T , indicating the number of test cases. For each test case:

The first contains two integers n and m (2n100,0mn) -- the length of the sequence and the number of known elements.

In the next m lines, each contains two integers xi and yi (1xin,0yi100,xi<xi+1,yiyi+1) , indicating that axi=yi .
 

Output
For each test case, output the answer as an irreducible fraction " p / q ", where p , q are integers, q>0 .
 

Sample Input
  
  
2 2 0 3 1 3 1
 

Sample Output
  
  
1/1 200/201
 

Author
zimpha
 

Source
 

题意:

    给定一个最长为100的序列,某些位置的值已确定,要求整个序列递减,且(a1+a2)/(sigma ai)的比值最大,ai的范围在0-100。


解题:

    因为使得整个值最大,可以直接想到,如果a1,a2值未定,则想办法让它们最大,其余未确定的值尽量小,向右看齐。


代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#define LL long long
using namespace std;
int v[105];
int gcd(int a,int b)
{
	if(a==0)return b;
	return gcd(b%a,a);
}
int main()
{
	int n,m,t,a,b,sum,fenzi,fenmu,d;
	scanf("%d",&t);
	while(t--)
	{
       scanf("%d%d",&n,&m);
	   if(m==0)
		   printf("1/1\n");
	   else
	   {
		   sum=0;
		   memset(v,-1,sizeof(v));
		   for(int i=0;i<m;i++)
		   {
			   scanf("%d%d",&a,&b);
			   v[a]=b;
		   }
		   v[n+1]=0;
		   for(int i=n;i>2;i--)
		   {
			   if(v[i]==-1)
				   v[i]=v[i+1];
               sum+=v[i];
		   }
           if(v[1]==-1&&v[2]==-1)
			   v[1]=v[2]=100;
		   else if(v[1]!=-1&&v[2]==-1)
			   v[2]=v[1];
		   else if(v[1]==-1)
			   v[1]=100;
		   sum+=v[1]+v[2];
           d=gcd(v[1]+v[2],sum);
		   printf("%d/%d\n",(v[1]+v[2])/d,sum/d);
	   }
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值