HDU 3836 Equivalent Sets

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=3836

Equivalent Sets

Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 104857/104857 K (Java/Others)
Total Submission(s): 3469    Accepted Submission(s): 1199


Problem Description
To prove two sets A and B are equivalent, we can first prove A is a subset of B, and then prove B is a subset of A, so finally we got that these two sets are equivalent.
You are to prove N sets are equivalent, using the method above: in each step you can prove a set X is a subset of another set Y, and there are also some sets that are already proven to be subsets of some other sets.
Now you want to know the minimum steps needed to get the problem proved.
 

 

Input
The input file contains multiple test cases, in each case, the first line contains two integers N <= 20000 and M <= 50000.
Next M lines, each line contains two integers X, Y, means set X in a subset of set Y.
 

 

Output
For each case, output a single integer: the minimum steps needed.
 

 

Sample Input
4 0 3 2 1 2 1 3
 

 

Sample Output
4 2
Hint
Case 2: First prove set 2 is a subset of set 1 and then prove set 3 is a subset of set 1.

 题意

给你一个有向图,问你至少需要添加多少条边构成强联通。

题解

先Tarjan缩点,然后统计有出度为0和入度为0的点的个数,取个最大值即可,至于为什么,请自行脑补。

代码

#include<iostream>
#include<vector>
#include<cstring>
#include<algorithm>
#include<stack>
#define MAX_N 20002
using namespace std;

vector<int> G[MAX_N];
int dfn[MAX_N],low[MAX_N],ind=0;
bool vis[MAX_N];
bool inStack[MAX_N];

stack<int> st;

int color[MAX_N],tot=0;

vector<int> newG[MAX_N];
vector<int> newrG[MAX_N];

void Tarjan(int u) {
    dfn[u] = low[u] = ++ind;
    vis[u] = 1;
    inStack[u] = 1;
    st.push(u);

    for (int i = 0; i < G[u].size(); i++) {
        int v = G[u][i];
        if (!vis[v]) {
            Tarjan(v);
            low[u] = min(low[u], low[v]);
        }
        else if (inStack[v])
            low[u] = min(dfn[v], low[u]);
    }
    if (dfn[u] == low[u]) {
        int x;
        do {
            x = st.top();
            st.pop();
            inStack[x] = 0;
            color[x] = tot;
        } while (x != u);
        tot++;
    }
}

int main() {
    int n, m;
    cin.sync_with_stdio(false);
    while (cin >> n >> m) {
        memset(vis, 0, sizeof(vis));
        memset(inStack, 0, sizeof(inStack));
        while (st.size())st.pop();
        for (int i = 0; i <= n; i++)G[i].clear();
        for (int i = 0; i <= n; i++)newG[i].clear();
        for (int i = 0; i <= n; i++)newrG[i].clear();
        ind = 0;
        tot = 0;
        memset(color, 0, sizeof(color));

        for (int i = 0; i < m; i++) {
            int u, v;
            cin >> u >> v;
            G[u].push_back(v);
        }
        for (int i = 1; i <= n; i++)
            if (!vis[i])Tarjan(i);
        for (int i = 1; i <= n; i++)
            for (int j = 0; j < G[i].size(); j++) {
                int u = color[i], v = color[G[i][j]];
                if (u == v)continue;
                newG[u].push_back(v);
                newrG[v].push_back(u);
            }
        if (tot == 1) {
            cout << 0 << endl;
            continue;
        }
        int a = 0, b = 0;
        for (int i = 0; i < tot; i++)if (newG[i].size() == 0)a++;
        for (int i = 0; i < tot; i++)if (newrG[i].size() == 0)b++;
        cout << max(a, b) << endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/HarryGuo2012/p/4715235.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值