HDU-1024_Max Sum Plus Plus

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

Input

Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.

Output

Output the maximal summation described above in one line.

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8

Hint

Huge input, scanf and dynamic programming is recommended.

题目大意:给N个数字,然后取X段的区间,要求这些区间的和最大。注意:区间不能重合。

题解:用f[i][j]表示前i个数第j个不相交的子段的最大值,则f[i][j] = max(f[i]][j],f[i][j-1]+a[i])。但是数组是1e6,会炸。所以用滚动数组,以j为最外层循环,这样f[i][j-1]可以在上一层处理出来。

附上代码

#include <algorithm>
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <queue>
#include <stack>

using namespace std;
const int INF = 1e9+7;
const int maxn = 1000050;

int a[maxn],dp[maxn],Max[maxn];//dp记录f[i][j-1],Max记录前i个f[i][j-1]最大值。

int main()
{
    int m,n,i,j,Max_sum;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            dp[i] = Max[i] = 0;
        }
        for(i=1;i<=m;i++)
        {
            Max_sum = -INF;
            for(j=i;j<=n;j++)
            {
                dp[j] = a[j] + max(dp[j-1],Max[j-1]);
                Max[j-1] = Max_sum;
                Max_sum = max(Max_sum,dp[j]);
            }
        }
        printf("%d\n",Max_sum);
    }
    return 0;
}

转载于:https://www.cnblogs.com/luoxiaoyi/p/9705581.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值