POJ 3694 Network

Network
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 12820 Accepted: 4660

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ AB ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ ABN), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0

题解:
  一句话题意:给一个无向图(有重边),每次有一个添边操作,要求每次操作后输出桥的总数。
  那么我们可以先tarjian标记图中的桥,边双缩点,如果在一个边双联通分量里加的边对答案没有影响,否则因为这个题目的数据比较水,我们把树建起来之后,暴力把树上x到y路径上的桥标记成没有就可以了。
  或者我们也可以树链剖分区间覆盖也可以,并查集也行。
  注意tarjian的时候由于有重编,所以不可以记点,只能记边的编号。

代码:
  
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<stdio.h>
#define MAXN 200010
using namespace std;
int dfn[MAXN],low[MAXN],is[MAXN],co[MAXN],fa[MAXN],dep[MAXN];
int n,m,num=1,hh=0;
bool b[MAXN];

struct egde{
  int first;
  int next;
  int to;
  int id;
}a[MAXN*2];

struct ed{
  int from,to;
}e[MAXN*2];

void addedge(int from,int to){
  a[++num].to=to;
  a[num].next=a[from].first;
  a[from].first=num;
}

void tarjian(int now,int id){
  dfn[now]=low[now]=++num;
  for(int i=a[now].first;i;i=a[i].next){
    int to=a[i].to;
    if((i^1)==id) continue;
    if(!dfn[to]){
      tarjian(to,i);
      low[now]=min(low[now],low[to]);
      if(low[to]>dfn[now]){
    e[++hh].from=now;e[hh].to=to;
    a[i].id=a[i^1].id=1;
      }
    }
    else low[now]=min(low[now],dfn[to]);
  }
}

void dfs(int now){
  co[now]=num;
  for(int i=a[now].first;i;i=a[i].next){
    int to=a[i].to;
    if(a[i].id||co[to]) continue;
    dfs(to);
  }
}

void pre(int now,int f){
  fa[now]=f;dep[now]=dep[f]+1;if(now!=1) b[now]=1;
  for(int i=a[now].first;i;i=a[i].next){
    int to=a[i].to;
    if(to==f) continue;
    pre(to,now);
  }
}

void work(int x,int y){
  if(b[y]) b[y]=0,hh--;
  if(b[x]) b[x]=0,hh--;
  while(x!=y){
    if(dep[y]>dep[x]) swap(x,y);
    x=fa[x];if(b[x]) b[x]=0,hh--;
  }
}

int main(){
  int t=0;
  while(1){
    scanf("%d%d",&n,&m);
    if(n==0&&m==0) break;
    t++;
    printf("Case %d:\n",t);
    num=1;memset(a,0,sizeof(a));
    for(int i=1;i<=m;i++){
      int x,y;scanf("%d%d",&x,&y);
      addedge(x,y);
      addedge(y,x);
    }
    num=0;memset(dfn,0,sizeof(dfn));
    for(int i=1;i<=n;i++) if(!dfn[i]) tarjian(i,0);num=0;
    memset(co,0,sizeof(co));
    for(int i=1;i<=n;i++) if(!co[i]) {num++;dfs(i);}
    num=0;memset(a,0,sizeof(a));
    for(int i=1;i<=hh;i++){
      int x=e[i].from,y=e[i].to;
      addedge(co[x],co[y]);
      addedge(co[y],co[x]);
    }
    pre(1,0);
    int q;cin>>q;
    while(q--){
      int x,y;scanf("%d%d",&x,&y);
      if(co[x]==co[y]){
    printf("%d\n",hh);continue;
      }
      else work(co[x],co[y]);
      printf("%d\n",hh);
    }
    puts("");
  }
}

 

转载于:https://www.cnblogs.com/renjianshige/p/9918065.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值