Fibonacci Numbers

Fibonacci Numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 81 Accepted Submission(s): 46
 
Problem Description
The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one.

What is the numerical value of the nth Fibonacci number?
 
Input
For each test case, a line will contain an integer i between 0 and 10 8 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than 8 digits, output only the first and last 4 digits of the answer, separating the two parts with an ellipsis (“...”).

There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).
 
 
Sample Input
0
1
2
3
4
5
35
36
37
38
39
40
64
65
 
Sample Output
0
1
1
2
3
5
9227465
14930352
24157817
39088169
63245986
1023...4155
1061...7723
1716...7565
 
 
Source
IPCP 2005 Northern Preliminary for Northeast North-America
 
Recommend
lcy
 
/*
题意:求第n个斐波那契数列的值,只需要前四位,后四位

初步思路:后四位好说,膜一下就行了重要的就是前四位.总共1e8的时间,感觉用大数爆都会超时

#补充:后四位矩阵膜10000就行了,前四位可以用通项公式取对数的方法求。

*/
#include<bits/stdc++.h>
#define ll long long
#define mod 10000
using namespace std;
/********************************矩阵模板**********************************/
class Matrix {
    public:
        int a[2][2];

        void init(int x) {
            memset(a,0,sizeof(a));
            if (x)
                for (int i = 0; i < 2 ; i++)
                    a[i][i] = 1;
        }

        Matrix operator +(Matrix b) {
            Matrix c;
            for (int i = 0; i < 2; i++)
                for (int j = 0; j < 2; j++)
                    c.a[i][j] = (a[i][j] + b.a[i][j]) % mod;
            return c;
        }

        Matrix operator +(int x) {
            Matrix c = *this;
            for (int i = 0; i < 2; i++)
                c.a[i][i] += x;
            return c;
        }

        Matrix operator *(Matrix b)
        {
            Matrix p; 
            p.init(0);
            for (int i = 0; i < 2; i++)
                for (int j = 0; j < 2; j++)
                for (int k = 0; k < 2; k++)
                    p.a[i][j] = (p.a[i][j] + (a[i][k]*b.a[k][j])%mod) % mod;
            return p;
        }

        Matrix power_1(int t) {
            Matrix Frist,p = *this;
            Frist.init(1);
            while (t) {
                if (t & 1)
                    Frist=Frist*p;
                p = p*p;
                t >>= 1;
            }
            return Frist;
        }
        
        Matrix power_2(Matrix a,Matrix b,int x){
            while(x){
                if(x&1){
                    b=a*b;
                }
                a=a*a;
                x>>=1;
            }
            return b;
        }
};
/********************************矩阵模板**********************************/
Matrix unit,init;
ll f[45];
ll n;
int main(){
    // freopen("in.txt","r",stdin);
    f[0]=0;
    f[1]=1;
    for(int i=2;i<40;i++){
        f[i]=f[i-1]+f[i-2];
    }
    while(scanf("%lld",&n)!=EOF){
        if(n<40){
            printf("%lld\n",f[n]);
            continue;
        }
        unit.a[0][0]=1;
        unit.a[0][1]=0;
        unit.a[1][0]=0;
        unit.a[1][1]=1;
        
        init.a[0][0]=1;
        init.a[0][1]=1;
        init.a[1][0]=1;
        init.a[1][1]=0;
        
        init=init.power_1(n-1);//有问题
        unit=unit*init;
        int Last=unit.a[0][0];
        
        long double Frist=-0.5 * log(5.0) / log(10.0) + ((long double)n) * log((sqrt(5.0)+1.0)/2.0) / log(10.0);
            Frist-=floor(Frist);
            Frist=pow(10,Frist);
            while(Frist<1000)
                Frist*=10;
        printf("%d...%04d\n",(int) Frist,Last);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/wuwangchuxin0924/p/6384810.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值