帧中继的点到点子接口配置: <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

分支AB之间的通信必须通过中心点,而且AB都可以与中心点通信。

步骤:1、分支AB之间的通信(过中心点)

      2、各分支与中心点的通信

 

Router 0

Press RETURN to get started!

 

 

 

Router>
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address <?xml:namespace prefix = st1 ns = "urn:schemas-microsoft-com:office:smarttags" />10.1.1.1 255.255.255.0
Router(config-if)#no shutdown

 

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface serial 0/0
Router(config-if)#no ip add
Router(config-if)#no ip address
Router(config-if)#encapsulation frame-relay
Router(config-if)#frame-relay lmi-type c
Router(config-if)#frame-relay lmi-type cisco
Router(config-if)#no shut
Router(config-if)#no shutdown

 

%LINK-5-CHANGED: Interface Serial0/0, changed state to up
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
Router(config-if)#
Router(config-if)#exit
Router(config)#interface serial 0/0.2 po
Router(config)#interface serial 0/0.2 point-to-point

 

%LINK-5-CHANGED: Interface Serial0/0.2, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0.2, changed state to upRouter(config-subif)#
Router(config-subif)#ip add
Router(config-subif)#ip address 12.12.12.1 255.255.255.0
Router(config-subif)#frame-relay int
Router(config-subif)#frame-relay interface-dlci 102

Router(config-subif)#exit
Router(config)#interface s
Router(config)#interface serial 0/0.3 po
Router(config)#interface serial 0/0.3 point-to-point

 

%LINK-5-CHANGED: Interface Serial0/0.3, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0.3, changed state to upRouter(config-subif)#
Router(config-subif)#ip address 13.13.13.1 255.255.255.0
Router(config-subif)#frame-relay int
Router(config-subif)#frame-relay interface-dlci 103

Router(config-subif)#exit
Router(config)#router rip
Router(config-router)#network 10.1.1.0 
Router(config-router)#network 12.12.12.0
Router(config-router)#network 13.13.13.0
Router(config-router)#exit
Router(config)#end
%SYS-5-CONFIG_I: Configured from console by console
Router#show frame-relay ?
  lmi  show frame relay lmi statistics
  map  Frame-Relay map table
  pvc  show frame relay pvc statistics
Router#show frame-relay ma
Router#show frame-relay map

Serial0/0.2 (up): point-to-point dlci, dlci 102, broadcast, status defined, active

Serial0/0.3 (up): point-to-point dlci, dlci 103, broadcast, status defined, active

Router#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is not set

 

     10.0.0.0/24 is subnetted, 1 subnets

C       10.1.1.0 is directly connected, FastEthernet0/0

     12.0.0.0/24 is subnetted, 1 subnets

C       12.12.12.0 is directly connected, Serial0/0.2

     13.0.0.0/24 is subnetted, 1 subnets

C       13.13.13.0 is directly connected, Serial0/0.3

R    172.16.0.0/16 [120/1] via 12.12.12.2, 00:00:17, Serial0/0.2

R    192.168.1.0/24 [120/1] via 13.13.13.2, 00:00:01, Serial0/0.3

Router#
Router#ping 12.12.12.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 12.12.12.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 46/55/62 ms

 

Router#ping 13.13.13.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 13.13.13.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 62/62/63 ms

 

Router#ping 172.16.1.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 63/87/94 ms

 

Router#ping 192.168.1.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 66/88/94 ms

 

Router#

 

 

 

 

Router 1:

Press RETURN to get started!

 

 

 

Router>en
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip add
Router(config-if)#ip address 172.16.1.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#no shutdown

 

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface serial 0/0
Router(config-if)#ip add
Router(config-if)#ip address 12.12.12.2 255.255.255.0
Router(config-if)#encapsulation frame-relay
Router(config-if)#frame-relay lmi-type ci
Router(config-if)#frame-relay lmi-type cisco
Router(config-if)#frame-relay map ip 12.12.12.1 201 b
Router(config-if)#frame-relay map ip 12.12.12.1 201 broadcast
Router(config-if)#no shut
Router(config-if)#no shutdown

 

%LINK-5-CHANGED: Interface Serial0/0, changed state to up
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
Router(config-if)#
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 172.16.1.0
Router(config-router)#network 12.12.12.0
Router(config-router)#end
%SYS-5-CONFIG_I: Configured from console by console
Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#interface serial 0/0

Router(config-if)#frame-relay map ip 13.13.13.2 201 b

Router(config-if)#frame-relay map ip 13.13.13.2 201 broadcast

Router(config-if)#no shutdown

 

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down

Router(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

 

Router(config-if)#end

%SYS-5-CONFIG_I: Configured from console by console

Router#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is not set

 

R    10.0.0.0/8 [120/1] via 12.12.12.1, 00:00:06, Serial0/0

     12.0.0.0/24 is subnetted, 1 subnets

C       12.12.12.0 is directly connected, Serial0/0

R    13.0.0.0/8 [120/1] via 12.12.12.1, 00:00:06, Serial0/0

     172.16.0.0/24 is subnetted, 1 subnets

C       172.16.1.0 is directly connected, FastEthernet0/0

R    192.168.1.0/24 [120/2] via 12.12.12.1, 00:00:06, Serial0/0

Router#show frame-relay map

Serial0/0 (up): ip 13.13.13.2 dlci 201, static, broadcast, CISCO, status defined, active

Serial0/0 (up): ip 12.12.12.1 dlci 201, static, broadcast, CISCO, status defined, active

Router#ping 12.12.12.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 12.12.12.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 34/54/63 ms

 

Router#ping 13.13.13.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 13.13.13.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 110/122/125 ms

 

Router#ping 10.1.1.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 93/93/94 ms

 

Router#ping 192.168.1.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 140/152/156 ms

 

Router#

 

 

 

Router 2

Press RETURN to get started!

 

 

 

Router>en
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#no shutdown

 

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface serial 0/0
Router(config-if)#ip address 13.13.13.2 255.255.255.0
Router(config-if)#encapsulation frame-relay
Router(config-if)#frame-relay lmi-type c
Router(config-if)#frame-relay lmi-type cisco
Router(config-if)#frame-relay map ip 13.13.13.1 301 b
Router(config-if)#frame-relay map ip 13.13.13.1 301 broadcast

Router(config-if)#no shut
Router(config-if)#no shutdown

 

%LINK-5-CHANGED: Interface Serial0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
Router(config-if)#
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 192.168.1.0
Router(config-router)#network 13.13.13.0
Router(config-router)#end
%SYS-5-CONFIG_I: Configured from console by console
Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#interface serial 0/0

Router(config-if)#frame-relay map ip 12.12.12.2 301 b

Router(config-if)#frame-relay map ip 12.12.12.2 301 broadcast

Router(config-if)#no shut

Router(config-if)#no shutdown

 

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down

Router(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

 

Router(config-if)#end

Router#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is not set

 

R    10.0.0.0/8 [120/1] via 13.13.13.1, 00:00:08, Serial0/0

R    12.0.0.0/8 [120/1] via 13.13.13.1, 00:00:08, Serial0/0

     13.0.0.0/24 is subnetted, 1 subnets

C       13.13.13.0 is directly connected, Serial0/0

R    172.16.0.0/16 [120/2] via 13.13.13.1, 00:00:08, Serial0/0

C    192.168.1.0/24 is directly connected, FastEthernet0/0

Router#show frame-relay map

Serial0/0 (up): ip 13.13.13.1 dlci 301, static, broadcast, CISCO, status defined, active

Serial0/0 (up): ip 12.12.12.2 dlci 301, static, broadcast, CISCO, status defined, active

Router#ping 12.12.12.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 12.12.12.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 47/50/63 ms

 

Router#ping 12.12.12.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 12.12.12.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 110/119/125 ms

 

Router#ping 10.1.1.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 78/81/94 ms

 

Router#ping 172.16.1.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 125/156/205 ms

 

Router#

 

中间的 Cloud-PT Cloud2 ( 帧中继云 ) 基本配置:

请参照上一帧中继配置。