HDU4763 - Theme Section

 

Problem Description
It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
 

 

Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 

 

Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
 

 

Sample Input
5
xy
abc
aaa
aaaaba
aaxoaaaaa
 

 

Sample Output
0
0
1
1
2
 
 
Source
 

 

Recommend
liuyiding
 

传送门

题意:给一个字符串,求它形式为EAEBE的最长的E的长度

思路:KMP,当A或B非空时,答案就只能是next[len]或0,for循环看一遍还有没有next[i]=len就OK,如果A和B均为空,那么最大长度就是循环节的k倍。

#include <bits/stdc++.h>
using namespace std;

const int N = 1e6+ 10;
char x[N];
int ne[N];

void kmp(int len) {
    int i = 0, j = ne[0] = -1;
    while (i < len) {
        while (j != -1 && x[i] != x[j]) j = ne[j];
        ne[++i] = ++j;
    }
}

int main() {
    int n;
    scanf("%d", &n);
    while (n--) {
        scanf("%s", x);
        memset(ne, 0, sizeof(ne));
        int len = strlen(x);
        if (len <= 2) { puts("0"); continue; }
        kmp(len);
        int d = len - ne[len];
        if (len % d == 0) {
            int ans = len / d;
            ans = ans / 3 * d;
            printf("%d\n", ans);
            continue;
        }
        int ans = 0;
        //for (int i = 0; i <= len; i++) printf("%d\n", ne[i]);
        for (int i = len - 1; i; i--) {
            if (ne[len] == ne[i]) {
                ans = ne[len];
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/Mrzdtz220/p/11063009.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值