集训第五周动态规划 D题 LCS

Description

In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do. 

Therefore the German government requires a program for the following task: 
Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind). 

Your country needs this program, so your job is to write it for us.

Input

The input will contain several test cases. 
Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '#'. 
Input is terminated by end of file.

Output

For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.

Sample Input

die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#

Sample Output

die einkommen der abgeordneten muessen dringend verbessert werden

这道题是LCS的变种,只需把数组类型改成string就可以了,重点在于对LCS模版的理解
LCS:求解最长公共子序列,由于动态规划无非是递归的一种优化,不如先来看看递归的解法
LCS(i,j)表示数组以数组1的i个为止和以数组2的第j个为止的最长公共子序列,注意是第i个字符为子串的末尾字符(这样才能达到无后效性的目的)
1.LCS(i-1,j-1)+1 (a【i】=b【j】)
LCS(i,j)={
2.max{LCS(i-1,j),LCS(i,j-1)} (a【i】!=b【j】)

对比递归,就能写出状态转移方程,可以用二维数组dp【i】【j】来表示状态LCS(i,j)
不过这个动态规划方程属于从已知推未知型,要特别注意给初始值

1.dp【i-1】【j-1】+1 (a【i】=b【j】) //如果相等,公共串的长度又加一了
 
   
               2.dp【i】【j】={  2.dp【0】【i】=0,dp【i】【0】=0           //初始值,如果某个数组的长度为0,那没必要说公共串了

3.max{dp【i-1】【j】,dp【i】【j-1】} (a【i】!=b【j】)   //如果不相等,只能选择前一个值最大的状态


然后再因题制宜,在dp寻求最长公共子串时记录一下选了哪些字符,最后输出就好
#include"iostream"
#include"cstring"
#include"cstdio"
using namespace std;

const int maxn=110;
string a[maxn],b[maxn],ans[maxn];
int dp[maxn][maxn],c[maxn][maxn],m,n;

void Init()
{
    memset(dp,0,sizeof(dp));
    int i=2,j=1;
    while(cin>>a[i]&&a[i]!="#") {i++;dp[i][0]=0;}
    m=i-1;
    while(cin>>b[j]&&b[j]!="#") {j++;dp[0][j]=0;}
    n=j-1;
   // memset(dp,0,sizeof(dp));
}

void Work()
{
    memset(c,0,sizeof(c));
    for(int i=1;i<=m;i++)
    {
        for(int j=1;j<=n;j++)
        {
            if(a[i]==b[j]) {dp[i][j]=dp[i-1][j-1]+1;c[i][j]=3;}
            else
            {
                if(dp[i-1][j]>dp[i][j-1])
                {
                    dp[i][j]=dp[i-1][j];
                    c[i][j]=1;
                }
                else
                {
                    dp[i][j]=dp[i][j-1];
                    c[i][j]=2;
                }
            }
        }
    }
}

void Print()
{
    int mn=dp[m][n];
    int i=m,j=n;
    while(mn)
    {
        while(c[i][j]!=3)
        {
            if(c[i][j]==1) i--;
            else j--;
        }
        ans[mn]=a[i];
        mn--;
        i--;j--;
    }
    int k;
    for(k=1;k<dp[m][n];k++) cout<<ans[k]<<" ";
    cout<<ans[k]<<endl;
}

int main()
{
    while(cin>>a[1])
    {
    Init();
    Work();
    Print();
    }
    return 0;
}
O(^_^)O
 
   

 



 

转载于:https://www.cnblogs.com/zsyacm666666/p/4724873.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值