hdu 5753 Permutation Bo

这里是一个比较简单的问题:考虑每个数对和的贡献。先考虑数列两端的值,两端的摆放的值总计有2种,比如左端:0,大,小;0,小,大;有1/2的贡献度。右端同理。

中间的书总计有6种可能。小,中,大。其中有两种对答案有贡献,即1/3的贡献度。加和计算可得到答案。

 

Permutation Bo

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 693    Accepted Submission(s): 421
Special Judge


Problem Description
There are two sequences  h1hn and c1cnh1hn is a permutation of 1n. particularly, h0=hn+1=0.

We define the expression [condition] is 1 when condition is True,is 0 when condition is False.

Define the function f(h)=ni=1ci[hi>hi1  and  hi>hi+1]

Bo have gotten the value of c1cn, and he wants to know the expected value of f(h).
 

 

Input
This problem has multi test cases(no more than  12).

For each test case, the first line contains a non-negative integer n(1n1000), second line contains n non-negative integer ci(0ci1000).
 

 

Output
For each test cases print a decimal - the expectation of  f(h).

If the absolute error between your answer and the standard answer is no more than 104, your solution will be accepted.
 

 

Sample Input
4 3 2 4 5 5 3 5 99 32 12
 

 

Sample Output
6.000000 52.833333
 

 

Author
绍兴一中
 
#include<iostream>
#include<stdio.h>
using namespace std;
int a[10005];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0; i<n; i++)
        {
            scanf("%d",a+i);
        }
        if(n==1)
        {
            printf("%.6lf\n",(a[0]+0.0));
            continue;
        }
        if(n==2)
        {
            printf("%.6lf\n",(a[0]+0.0+a[1])/2);
            continue;
        }
        double ans=0.0;
        ans=(a[0]+0.0+a[n-1]+0.0);
        ans/=2;
        double tmp=0.0;
        for(int i=1; i<n-1; i++)
        {
            tmp+=(a[i]+0.0);
        }
        tmp/=3;
        ans+=tmp;
        printf("%.6lf\n",ans);


    }
    return 0;

}
View Code

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值