HDU5753 Permutation Bo

题目链接:HDU5753

Permutation Bo

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 451    Accepted Submission(s): 269
Special Judge


Problem Description
There are two sequences  h1hn  and  c1cn h1hn  is a permutation of  1n . particularly,  h0=hn+1=0 .

We define the expression  [condition]  is 1 when  condition  is True,is 0 when  condition  is False.

Define the function  f(h)=ni=1ci[hi>hi1  and  hi>hi+1]

Bo have gotten the value of  c1cn , and he wants to know the expected value of  f(h) .
 

Input
This problem has multi test cases(no more than  12 ).

For each test case, the first line contains a non-negative integer  n(1n1000) , second line contains  n  non-negative integer  ci(0ci1000) .
 

Output
For each test cases print a decimal - the expectation of  f(h) .

If the absolute error between your answer and the standard answer is no more than  104 , your solution will be accepted.
 

Sample Input
  
  
4 3 2 4 5 5 3 5 99 32 12
 

Sample Output
  
  
6.000000 52.833333
 
题意:2个序列h1~hn,c1~cn,第一个是1到n的一个排列,ans是c1到cn的连加,如果ci对应的hi比它周围2个数都大的话就去ci的值,否则不取。问结果的期望是多少。

题目分析:先求每个点取的概率,两边的点只与1个数比较,所以概率1/2,中间的点与2个数比较,概率1/3;之后求期望即可。注意对1的特判。

//
//  main.cpp
//  Permutation Bo
//
//  Created by teddywang on 2016/7/27.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
    int n;
    double ans,buf;
    while(cin>>n)
    {
        ans=0;
        if(n==1)
        {
            cin>>buf;
            printf("%.6lf\n",buf);
        }
        else
        {
            for(int i=0;i<n;i++)
            {
                cin>>buf;
                if(i==0||i==n-1)
                {
                    ans+=buf/2;
                }
                else ans+=buf/3;
            }
            printf("%.6lf\n",ans);
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值