路由重分发的关键在于asbr的配置,这里为r2/r5,r2的s0/0属于 ospf ,e1/0属于eigrp ,r5的s0/0属于eigrp,e1/0属于rip v2.

具体asbr的配置:

r2:

!        
!        
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!        
interface Serial0/0
 ip address 24.0.0.2 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!        
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!        
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!        
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!        
interface Ethernet1/0
 ip address 23.0.0.1 255.255.255.0
 half-duplex
!        
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!        
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!        
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!        
router eigrp 90
 redistribute ospf 100
 network 2.2.2.0 0.0.0.255
 network 23.0.0.0 0.0.0.255
 default-metric 1000 10 255 1 1500
 auto-summary
!        
router ospf 100
 log-adjacency-changes
 redistribute eigrp 90 subnets
 network 24.0.0.0 0.0.0.255 area 1
!        
no ip http server
no ip http secure-server
!        
!        
!        
!        
!        
!        
control-plane
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!        
!        
end

r5:

 

!        
!        
!        
!        
interface Loopback0
 ip address 5.5.5.5 255.255.255.0
!        
interface Serial0/0
 ip address 35.0.0.2 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!        
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!        
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!        
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!        
interface Ethernet1/0
 ip address 15.0.0.1 255.255.255.0
 half-duplex
!        
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!        
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!        
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!        
router eigrp 90
 redistribute rip
 network 35.0.0.0 0.0.0.255
 default-metric 1000 30 255 1 1500
 auto-summary
!        
router rip
 version 2
 redistribute eigrp 90
 network 5.0.0.0
 network 15.0.0.0
 default-metric 10
!        
no ip http server
no ip http secure-server
!        
!        
!        
!        
!        
!        
control-plane
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4